Bug 206333 - mail/thunderbird www/firefox-esr www/libxul www/seamonkey: fix build with clang 3.8.0
Summary: mail/thunderbird www/firefox-esr www/libxul www/seamonkey: fix build with cla...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-gecko mailing list
URL:
Keywords:
: 206545 (view as bug list)
Depends on:
Blocks: 206074
  Show dependency treegraph
 
Reported: 2016-01-17 14:21 UTC by Dimitry Andric
Modified: 2016-01-27 19:31 UTC (History)
0 users

See Also:
jbeich: maintainer-feedback+


Attachments
Remove superfluous (and ambiguous) forward declarations from MessageEvent.h (989 bytes, patch)
2016-01-17 14:21 UTC, Dimitry Andric
jbeich: maintainer-approval+
Details | Diff
Remove forward declarations from MessageEvent.h (4.04 KB, patch)
2016-01-24 15:57 UTC, Dimitry Andric
jbeich: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dimitry Andric freebsd_committer 2016-01-17 14:21:42 UTC
Created attachment 165713 [details]
Remove superfluous (and ambiguous) forward declarations from MessageEvent.h

During the exp-run in bug 206074, it was found that www/libxul gives errors with a recent clang 3.8.0 snapshot:

http://package18.nyi.freebsd.org/data/headamd64PR206074-default/2016-01-15_15h26m58s/logs/errors/libxul-38.5.2.log

This is caused by unneeded forward declarations of class MessagePort, MessagePortBase and MessagePortList.  These should be removed.

Obtained from: https://github.com/jsonn/pkgsrc/blob/trunk/www/firefox38/patches/patch-dom_events_MessageEvent.h
Comment 1 Jan Beich freebsd_committer 2016-01-20 11:14:06 UTC
Comment on attachment 165713 [details]
Remove superfluous (and ambiguous) forward declarations from MessageEvent.h

Looks fine. It seems the last affected version was Firefox 42.0. ESR45 arrives in April, so not much point in upstreaming as mozilla-central isn't affected.
Comment 2 Jan Beich freebsd_committer 2016-01-24 00:29:46 UTC
*** Bug 206545 has been marked as a duplicate of this bug. ***
Comment 3 Dimitry Andric freebsd_committer 2016-01-24 15:57:28 UTC
Created attachment 166067 [details]
Remove forward declarations from MessageEvent.h

Here is a patch that handles mail/thunderbird, www/firefox-esr, www/libxul, and www/seamonkey.
Comment 4 Dimitry Andric freebsd_committer 2016-01-25 19:49:12 UTC
So, is this OK to commit now? :)
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2016-01-25 19:50:34 UTC
@Jan, I notice you're not listed on the Gecko team page on the wiki, but I'm assuming you're on the team.

If so, could you add yourself to the wiki page, and while you're here, also confirm whether or not Dimitry is clear to assign this issue to himself and commit.

Thanks!
Comment 6 Jan Beich freebsd_committer 2016-01-26 03:01:23 UTC
(In reply to Kubilay Kocak from comment #5)
> ... I'm assuming you're on the team.

https://lists.freebsd.org/pipermail/freebsd-gecko/2015-September/005697.html

> ... confirm whether or not Dimitry is clear to ... commit.

comment 1 also applies to the last maintainer-approval+ as well. For better visibility/coordination in case of regressions, etc. leave Assignee as is or add gecko@ to CC.

So, go ahead and land.
Comment 7 commit-hook freebsd_committer 2016-01-26 19:55:50 UTC
A commit references this bug:

Author: dim
Date: Tue Jan 26 19:55:14 UTC 2016
New revision: 407301
URL: https://svnweb.freebsd.org/changeset/ports/407301

Log:
  During the exp-run in bug 206074, it was found that www/libxul gives
  errors with a recent clang 3.8.0 snapshot:

  ../../dist/include/mozilla/dom/MessageEvent.h:61:32: error: reference to 'MessagePort' is ambiguous
    void SetSource(mozilla::dom::MessagePort* aPort);
                                 ^

  This is caused by unneeded forward declarations of class MessagePort,
  MessagePortBase and MessagePortList.  These can be removed.

  Obtained from:	pkgsrc
  Approved by:	jbeich (maintainer)
  PR:		206333
  MFH:		2016Q1

Changes:
  head/mail/thunderbird/files/patch-mozilla-dom-events-MessageEvent.h
  head/www/firefox-esr/files/patch-dom-events-MessageEvent.h
  head/www/libxul/files/patch-dom-events-MessageEvent.h
  head/www/seamonkey/files/patch-mozilla-dom-events-MessageEvent.h
Comment 8 commit-hook freebsd_committer 2016-01-27 19:30:42 UTC
A commit references this bug:

Author: dim
Date: Wed Jan 27 19:29:55 UTC 2016
New revision: 407377
URL: https://svnweb.freebsd.org/changeset/ports/407377

Log:
  MFH: r407301

  During the exp-run in bug 206074, it was found that www/libxul gives
  errors with a recent clang 3.8.0 snapshot:

  ../../dist/include/mozilla/dom/MessageEvent.h:61:32: error: reference to 'MessagePort' is ambiguous
    void SetSource(mozilla::dom::MessagePort* aPort);
                                 ^

  This is caused by unneeded forward declarations of class MessagePort,
  MessagePortBase and MessagePortList.  These can be removed.

  Obtained from:	pkgsrc
  Approved by:	ports-secteam (delphij)
  PR:		206333

Changes:
_U  branches/2016Q1/
  branches/2016Q1/mail/thunderbird/files/patch-mozilla-dom-events-MessageEvent.h
  branches/2016Q1/www/firefox-esr/files/patch-dom-events-MessageEvent.h
  branches/2016Q1/www/libxul/files/patch-dom-events-MessageEvent.h
  branches/2016Q1/www/seamonkey/files/patch-mozilla-dom-events-MessageEvent.h