Bug 206340 - databases/pgadmin3: please update to 1.22; PostgreSQL 9.5 not supported by port
Summary: databases/pgadmin3: please update to 1.22; PostgreSQL 9.5 not supported by port
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Max Khon
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-17 17:58 UTC by O. Hartmann
Modified: 2016-02-10 12:21 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (fjoe)


Attachments
svn-diff_databases_pgadmin3-1.22.0 (1.37 KB, patch)
2016-01-18 23:52 UTC, w.schwarzenfeld
no flags Details | Diff
portlint-databases_pgadmi3-1.22.0 (519 bytes, text/plain)
2016-01-18 23:53 UTC, w.schwarzenfeld
no flags Details
poudriere-databases_pgadmin3-1.22.0.log (534.28 KB, text/x-log)
2016-01-19 00:20 UTC, w.schwarzenfeld
no flags Details
svn-diff_databases_pgadmin3-1.22.0 (1.51 KB, patch)
2016-01-19 02:22 UTC, w.schwarzenfeld
no flags Details | Diff
svn-diff_databases_pgadmin3-1.22.0 (1.46 KB, patch)
2016-01-19 02:45 UTC, w.schwarzenfeld
no flags Details | Diff
svn-diff_pgadmin3-1.22.0 (1.48 KB, patch)
2016-01-19 09:48 UTC, w.schwarzenfeld
no flags Details | Diff
svn-diff_databases_pgadmin3-1.22.1 (1.37 KB, patch)
2016-02-09 21:40 UTC, w.schwarzenfeld
no flags Details | Diff
poudriere_databases_pgadmin3-1.22.1.log (536.05 KB, text/x-log)
2016-02-09 22:08 UTC, w.schwarzenfeld
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2016-01-17 17:58:20 UTC
The port database/pgadmin3 is of Release 1.20, which does not support PostgreSQl 9.5. Pgadmin III is available as version 1.22, supporting PostgreSQL 9.5 now - see postgresql.org
Comment 1 w.schwarzenfeld 2016-01-18 23:52:57 UTC
Created attachment 165783 [details]
svn-diff_databases_pgadmin3-1.22.0
Comment 2 w.schwarzenfeld 2016-01-18 23:53:38 UTC
Created attachment 165784 [details]
portlint-databases_pgadmi3-1.22.0
Comment 3 w.schwarzenfeld 2016-01-19 00:20:43 UTC
Created attachment 165787 [details]
poudriere-databases_pgadmin3-1.22.0.log
Comment 4 w.schwarzenfeld 2016-01-19 00:21:45 UTC
Provided the files cause of an question about in freebsd.forum, but cannot test functionallity (Never worked with it).
Comment 5 w.schwarzenfeld 2016-01-19 02:22:53 UTC
Created attachment 165789 [details]
svn-diff_databases_pgadmin3-1.22.0
Comment 6 w.schwarzenfeld 2016-01-19 02:45:29 UTC
Created attachment 165790 [details]
svn-diff_databases_pgadmin3-1.22.0
Comment 7 w.schwarzenfeld 2016-01-19 02:54:19 UTC
Ok, it starts, connects to a database and seems to work.
Comment 8 O. Hartmann 2016-01-19 08:42:14 UTC
Confirmed - it seemes to work for me, too. Only some cosmetics to the Makefile:

PORTREVISION schould be unset or 0, the trailing backslash on line 

BUILD_DEPENDS=  sphinx-build:${PORTSDIR}/textproc/py-sphinx \

should be erased - on my opinion.

Thanks for the fast answer and salvation of the problem.

Regards,
oh
Comment 9 w.schwarzenfeld 2016-01-19 09:48:14 UTC
Created attachment 165803 [details]
svn-diff_pgadmin3-1.22.0
Comment 10 O. Hartmann 2016-02-08 18:37:02 UTC
As this patch works for me now for a couple of weeks, can we submit/commit it? It would be nice. Thank you.
Comment 11 Kurt Jaeger freebsd_committer 2016-02-09 20:06:33 UTC
Testbuilds@work, with 1.22.1.
Comment 12 w.schwarzenfeld 2016-02-09 21:40:47 UTC
Created attachment 166816 [details]
svn-diff_databases_pgadmin3-1.22.1
Comment 13 w.schwarzenfeld 2016-02-09 22:08:28 UTC
Created attachment 166817 [details]
poudriere_databases_pgadmin3-1.22.1.log
Comment 14 w.schwarzenfeld 2016-02-09 22:09:00 UTC
The files for the new version 1.22.1. (portlint does not change).
Comment 15 Kurt Jaeger freebsd_committer 2016-02-10 05:36:11 UTC
Testbuilds all fine on 11a, 10.2a+i, 9.3a.
Comment 16 commit-hook freebsd_committer 2016-02-10 12:15:09 UTC
A commit references this bug:

Author: fjoe
Date: Wed Feb 10 12:14:55 UTC 2016
New revision: 408624
URL: https://svnweb.freebsd.org/changeset/ports/408624

Log:
  Update to 1.22.1

  PR:		206340

Changes:
  head/databases/pgadmin3/Makefile
  head/databases/pgadmin3/distinfo