Bug 206461 - Geom redboot module fis offset problem
Summary: Geom redboot module fis offset problem
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: CURRENT
Hardware: mips Any
: --- Affects Some People
Assignee: freebsd-geom mailing list
URL:
Keywords: patch
: 206462 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-01-21 10:15 UTC by HIROKI MORI
Modified: 2018-08-05 01:21 UTC (History)
0 users

See Also:


Attachments
geom_redboot patch (1.13 KB, patch)
2016-01-21 10:15 UTC, HIROKI MORI
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description HIROKI MORI 2016-01-21 10:15:07 UTC
Created attachment 165905 [details]
geom_redboot patch

Current source code(sys/geom/geom_redboot.c) is check only last block and first block. But FON2201 router is 2 block before at last.

RedBoot> fis list
Name              FLASH addr  Mem addr    Length      Entry point
RedBoot           0xA8000000  0xA8000000  0x00030000  0x00000000
FIS directory     0xA87E0000  0xA87E0000  0x0000F000  0x00000000
RedBoot config    0xA87EF000  0xA87EF000  0x00001000  0x00000000

I add setting FIS directory offset by hint. Please consider this patch.

Thanks.

Hiroki Mori
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2016-01-22 01:04:43 UTC
*** Bug 206462 has been marked as a duplicate of this bug. ***
Comment 2 HIROKI MORI 2018-08-05 01:21:15 UTC
This patch is include this revision.

https://svnweb.freebsd.org/base?view=revision&revision=306678