Bug 206466 - net/3proxy version: 0.8.0 not work
Summary: net/3proxy version: 0.8.0 not work
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Kurt Jaeger
URL:
Keywords: easy, patch, patch-ready, regression
Depends on:
Blocks:
 
Reported: 2016-01-21 13:28 UTC by agr
Modified: 2016-01-25 16:45 UTC (History)
2 users (show)

See Also:
koobs: maintainer-feedback+


Attachments
patch to 0.8.1 (932 bytes, patch)
2016-01-21 15:32 UTC, Pavel Timofeev
timp87: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description agr 2016-01-21 13:28:50 UTC
After update net/3proxy: 0.7.1.3 -> 0.8.0

3proxy not work.

0.7.1.3 - work fine

sockstat -4 | grep 3proxy
nobody   3proxy     16688 6  tcp4   10.0.0.223:3128       *:*
nobody   3proxy     16688 7  tcp4   10.0.0.223:8082       *:*


Version 0.8.0 - not work

sockstat -4 | grep 3proxy
nobody   3proxy     16688 6  tcp4   *:*       *:*
nobody   3proxy     16688 7  tcp4   *:*       *:*

log 0.8.0
10.0.0.223 - - [21/01/2016:10:48:28 +0500] "bind(): Invalid argument" 00000 0 0 ADMIN/10.0.0.223:0
10.0.0.223 - - [21/01/2016:10:48:31 +0500] "bind(): Invalid argument" 00000 0 0 PROXY/10.0.0.223:0
10.0.0.223 - - [21/01/2016:10:48:31 +0500] "bind(): Invalid argument" 00000 0 0 ADMIN/10.0.0.223:0
10.0.0.223 - - [21/01/2016:10:48:38 +0500] "bind(): Invalid argument" 00000 0 0 PROXY/10.0.0.223:0
10.0.0.223 - - [21/01/2016:10:48:38 +0500] "bind(): Invalid argument" 00000 0 0 ADMIN/10.0.0.223:0
10.0.0.223 - - [21/01/2016:10:48:51 +0500] "bind(): Invalid argument" 00000 0 0 PROXY/10.0.0.223:0
Comment 1 Pavel Timofeev 2016-01-21 14:14:32 UTC
(In reply to agr from comment #0)
Please, show your config file and ifconfig output at least.
Comment 2 agr 2016-01-21 14:46:41 UTC
re0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=8209b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_MAGIC,LINKSTATE>
        ether 71:72:ac:ce:37:91
        inet 10.0.0.223 netmask 0xffffff00 broadcast 10.0.0.255
        media: Ethernet autoselect (100baseTX <full-duplex>)
        status: active

---

#!/usr/local/bin/3proxy
###############################################################
# ver: 0.3a (25-04-2010)                                      #
# ver: 0.4.1 (27-04-2010)                                     #
# ver: 0.4.2 (01-05-2010)    dasable nscache                  #
# ver: 0.5   (05-04-2011) rewrite for koms server             #
# ver: 0.5.1 (14-05-2014) rewrite for koms server             #
###############################################################
daemon
internal 10.0.0.223
external 10.0.0.223
nserver 81.30.199.5
nserver 81.30.199.94
nserver 10.0.0.220
#fakeresolve
#dnspr
nscache 65536
maxconn 200

#nsrecord irr.ru google.ru
#nsrecord monolith.irr.ru google.ru
#nsrecord pronto.ru google.ru
#nsrecord kh.google.com google.ru

timeouts 1 5 30 60 180 1800 15 60
monitor "/usr/local/etc/3proxy.cfg"
###############################################################
logformat "L%C - %U [%d/%m/%Y:%H:%M:%S %z] ""%T"" %E %I %O %N/%R:%r"
log /var/log/3proxy/3proxy.log D
counter "/var/log/3proxy/3proxy.3cf" D "/var/log/3proxy/traf"
rotate 100
###############################################################
# countin <number> <type> <amount> <userlist> <sourcelist> <targetlist> <targetportlist> <commandlist>
###############################################################
countin "1/For home use" M * aaa * * * *
countin "2/Media Center" M * bbb * * * *

users admin:CL:000000000
users bbb:CL:1111111111
users aaa:CL:2222222222
###############################################################
bandlimin 1024000 * * * * *
auth iponly

plugin /usr/local/lib/3proxy/PCREPlugin.so pcre_plugin
pcre cliheader deny "masturbat|mature|moviemonster|znakomstva"

bandlimin 256000 * 10.0.0.109
bandlimin 256000 * 10.0.0.110

countin "01/10.0.0.109 - mnogo vremeni svobodnogo" M 3000 * 10.0.0.109 * * *
countin "01/10.0.0.110 - mnogo vremeni svobodnogo" M 3000 * 10.0.0.110 * * *

allow * * *komandirovka.ru*,*radiorecord.ru*,*sberbank-online.ru*
deny * * *youtube*,*torrent*,*bar*,*love*,*sex*,*porn*,*vk.me*,*proxy*,*anonym*,*xvideo*,*runetki*,*xxx*,*fuck*,*westim.ru*,*fineone.ru*,*fo
deny * * *ok.ru*,*mediarotate.com*,*xn--80ac5ab.xn--p1ai*,*mamb*,*allsport365.com*,*11x11.ru*,*myscore.ru*,*mixmarket.biz*,*bet365.es*,*bets
deny * * *newnewnew.ru*,*tube*,*vk.com*,*dostup*,*anonim*,*fastbuh.ru*,*serqus.ru*,*aradero.ru*,*vkdor.ru*,*arendadorogo.ru*,*recker.ru*,*fo
deny * * *fuck*,*sux*,*piss*,*girl*,*nude*,*suka*,*ivi.ru*,*amazonaws.com*,*rugailo.net*,*pirateplayer.com*,*namba.kz*,*cinema*,*kino*,*slop
deny * * *icq.com*,*jivosite.com*,*tnt*,*serializm.com*,*vkontakte.ru*,*lublyutebya.ru*,*24open.ru*,*funcaptcha.com*,*pussy*,*rucaptcha.com*
deny * * 78.140.208.0/24,78.140.209.0/24,193.0.171.24
deny * * *.cc*,*.tv*,*igr*,*.io*
allow * 10.0.0.0/24 * * * 1-7 08:00:00-22:00:00
deny *
proxy -p3128 -n

###############################################################
# Administration section                                      #
###############################################################
flush
auth strong
allow admin * * 8082 * *
deny *
admin -p8082
###############################################################
# Запускаем сервер от пользователя nobody
# (возможно в вашей ОС uid и gid пользователя nobody
# будут другими. Для их определения воспользуйтесь коммандой id nobody)
#chroot /usr/local/jail
setgid 65534
setuid 65534
###############################################################
# После того как мы создали конфигурационный файл сервера, запускаем 3proxy командой:
# /usr/local/3proxy/3proxy /usr/local/3proxy/3proxy.cfg
# $Id: example1.txt,v 1.5 2006/02/08 17:59:07 vlad Exp $
###############################################################
end
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2016-01-21 14:49:00 UTC
@Agr, please don't post inappropriate content (even though its legitimate) on the issue tracker. Instead please sanitize it.

Also, please use attachments for large bodies of text, configuration files, or logs, instead of posting them in comments.
Comment 4 Pavel Timofeev 2016-01-21 15:32:41 UTC
Created attachment 165918 [details]
patch to 0.8.1

They just released 0.8.1 version. Here is a patch. Please, check if it helps.
Comment 5 Pavel Timofeev 2016-01-21 15:35:19 UTC
The only change is
- 0.8.1 fixes bug with destination networks on ACLs
Comment 6 commit-hook freebsd_committer 2016-01-21 20:16:32 UTC
A commit references this bug:

Author: pi
Date: Thu Jan 21 20:16:15 UTC 2016
New revision: 406874
URL: https://svnweb.freebsd.org/changeset/ports/406874

Log:
  net/3proxy: 0.8.0 -> 0.8.1, fixes bug with destination networks on ACLs

  PR:		206466
  Submitted by:	timp87@gmail.com (maintainer)

Changes:
  head/net/3proxy/Makefile
  head/net/3proxy/distinfo
Comment 7 Kurt Jaeger freebsd_committer 2016-01-21 20:17:02 UTC
Committed, fixed. Thanks!
Comment 8 Pavel Timofeev 2016-01-22 08:32:42 UTC
(In reply to agr from comment #2)
@Agr, could you, please, confirm your problem has gone after the update?
Comment 9 agr 2016-01-22 11:49:27 UTC
problem not resolved.
Comment 10 Pavel Timofeev 2016-01-22 12:00:37 UTC
(In reply to agr from comment #9)
Ok, I think we should create bug report for 3proxy. I'll provide a link a bit later.
Comment 11 Pavel Timofeev 2016-01-22 12:09:45 UTC
(In reply to agr from comment #9)
Let's not spam here, but there https://github.com/z3APA3A/3proxy/issues/32
Comment 12 Pavel Timofeev 2016-01-25 08:07:06 UTC
(In reply to agr from comment #9)
Look here https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=206596
Comment 13 Pavel Timofeev 2016-01-25 10:57:32 UTC
(In reply to agr from comment #9)
Please, check that 0.8.2, which has just been committed to the ports tree, works for you.
Comment 14 Pavel Timofeev 2016-01-25 16:45:02 UTC
(In reply to timp87 from comment #13)
Oh, turns out, that's not all :( Waiting for the 0.8.3 release.
Comment 15 Pavel Timofeev 2016-01-25 16:45:15 UTC
(In reply to timp87 from comment #13)
Oh, turns out, that's not all :( Waiting for the 0.8.3 release.