Bug 206545 - mail/thunderbird: fix build with clang 3.8.0
Summary: mail/thunderbird: fix build with clang 3.8.0
Status: Closed DUPLICATE of bug 206333
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-gecko mailing list
URL:
Keywords:
Depends on:
Blocks: 206074
  Show dependency treegraph
 
Reported: 2016-01-23 22:52 UTC by Dimitry Andric
Modified: 2016-01-24 00:49 UTC (History)
0 users

See Also:
jbeich: maintainer-feedback+


Attachments
Remove superfluous (and ambiguous) forward declarations from MessageEvent.h (1.04 KB, patch)
2016-01-23 22:52 UTC, Dimitry Andric
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dimitry Andric freebsd_committer 2016-01-23 22:52:11 UTC
Created attachment 166031 [details]
Remove superfluous (and ambiguous) forward declarations from MessageEvent.h

During the exp-run in bug 206074, it was found that mail/thunderbird gives errors with a recent clang 3.8.0 snapshot [1]:

../../dist/include/mozilla/dom/MessageEvent.h:61:32: error: reference to 'MessagePort' is ambiguous
  void SetSource(mozilla::dom::MessagePort* aPort);
                               ^
../../dist/include/mozilla/dom/MessagePort.h:54:7: note: candidate found by name lookup is 'mozilla::dom::MessagePort'
class MessagePort final : public MessagePortBase
      ^
../../dist/include/mozilla/dom/MessageEvent.h:18:7: note: candidate found by name lookup is 'mozilla::dom::MessagePort'
class MessagePort;
      ^

Similar to bug 206333 (for www/libxul), this is caused by unneeded forward declarations of class MessagePort, MessagePortBase and MessagePortList.  These should be removed.

Obtained from: https://github.com/jsonn/pkgsrc/blob/trunk/www/firefox38/patches/patch-dom_events_MessageEvent.h

[1] http://package18.nyi.freebsd.org/data/headamd64PR206074-default/2016-01-15_15h26m58s/logs/errors/thunderbird-38.5.0.log
Comment 1 Jan Beich freebsd_committer 2016-01-24 00:29:46 UTC
> Similar to bug 206333 (for www/libxul)

Not similar but identical. They share main code base. www/seamonkey and mail/thunderbird have the same code lying under mozilla/ subdirectory. www/seamonkey currently lags behind a version: (2.39 - 2) * 100 + 3 = 42.0

Please, fix in a single commit: www/firefox-esr, www/libxul, mail/thunderbird, www/seamonkey.

*** This bug has been marked as a duplicate of bug 206333 ***
Comment 2 Jan Beich freebsd_committer 2016-01-24 00:49:37 UTC
> 42.0

This is firefox (engine) version that can also be found under config/milestone.txt or
mozilla/config/milestone.txt. The version is useful to keep in mind when applying patches (before trying to build). For one, after www/seamonkey catches up with www/firefox it should build fine.