Bug 206619 - "About FreeBSD" page promises "full source code"
Summary: "About FreeBSD" page promises "full source code"
Status: Closed Works As Intended
Alias: None
Product: Documentation
Classification: Unclassified
Component: Website (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: FreeBSD doc mailing list
URL: https://www.freebsd.org/about.html
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-25 19:12 UTC by Fabian Keil
Modified: 2016-08-02 21:53 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian Keil 2016-01-25 19:12:20 UTC
The "About FreeBSD" page (https://www.freebsd.org/about.html) claims:
"FreeBSD is available free of charge and comes with full source code."

The "full source code" part is unfortunately false as FreeBSD
contains sourceless host and microcode.
Comment 1 Fabian Keil 2016-01-26 10:01:58 UTC
Please clarify what you think "Works As Intended".

I did not file this bug against the non-free binary blobs
in base, but against the website which incorrectly claims
that FreeBSD "comes with full source code".

To fix this bug, the sentence could be reworded to something
like: "FreeBSD is available free of charge, parts of it come
with source code."
Comment 2 Conrad Meyer freebsd_committer 2016-01-26 15:55:04 UTC
You elided the first half of the sentence: "While you might expect an operating system with these features to sell for a high price,"

Clearly the reference is to other *operating systems*, which cost money or don't ship their source (Windows).  Perhaps the reference is dated.

FreeBSD ships the full source of the operating system FreeeBSD releases.  You get everything we get.  We are generally not interested in tilting against the "binary firmware blobs aren't open source!" windmill.
Comment 3 Fabian Keil 2016-01-27 19:30:34 UTC
Thanks for the clarification.

Obviously I still consider the sentence false and misleading,
but at least it's clear to me now that you disagree.

FYI, I'm reasonably sure that if you get Windows from a vendor
other than Microsoft itself, you get all the sources the vendor
has as well.
Comment 4 commit-hook freebsd_committer 2016-08-02 21:53:37 UTC
A commit references this bug:

Author: emaste
Date: Tue Aug  2 21:53:12 UTC 2016
New revision: 49208
URL: https://svnweb.freebsd.org/changeset/doc/49208

Log:
  update description of included source code on about page

  Avoid quibbling over device firmware files that do not include source
  code. It's clear from the context that this (perhaps dated) paragraph
  is making a comparison to closed-source operating systems, but the
  sentence may be interpreted differently in 2016.

  PR:		206619
  Reviewed by:	wblock
  Differential Revision:	https://reviews.freebsd.org/D5628

Changes:
  head/en_US.ISO8859-1/htdocs/about.xml