Bug 206731 - sysutils/bareos-server 15.2.2_1 fails to make with prior jansson installation
Summary: sysutils/bareos-server 15.2.2_1 fails to make with prior jansson installation
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Jose Alonso Cardenas Marquez
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-29 07:40 UTC by niemand
Modified: 2016-02-01 08:03 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (acm)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description niemand 2016-01-29 07:40:53 UTC
jansson support seems to be required to get latest version 15.2.2 of bareos-webui to work:

https://bugs.bareos.org/view.php?id=543

My tries:
On FreeBSD 10.2 AMD64: 
bareos 15.2.2_1 make install clean succeeds but without jansson support.

But:
bareos-webui 15.2.2 fails in browser with the description of bug: 
https://bugs.bareos.org/view.php?id=543 when using bareos-server without jansson support:

"Error: API 2 not available on director. Please upgrade to version 15.2.1 or greater and/or compile with jansson support."

Alternative approach tested:
1. install jansson via ports/devel/jansson version 2.7_1
2. make bareos-server 15.2.2_1

Here, the bareos-server make fails.
How to include jansson support for bareos-server 15.2.2_1 ?
Comment 1 Jose Alonso Cardenas Marquez freebsd_committer 2016-01-30 05:13:14 UTC
Please, try with new version of bareos-*. I have added jansson support into bareos-client and bareos-server.
Comment 2 niemand 2016-02-01 08:03:20 UTC
It is working fine now with bareos-server 15.2.2_2 and bareos-webui 15.2.2 from the ports.
Thank you very much!
Kind regards