Bug 206738 - sysutils/devcpu-data: unable to update via portmaster -- license dialog hidden in log file
Summary: sysutils/devcpu-data: unable to update via portmaster -- license dialog hidde...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: Stefan Esser
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-29 15:48 UTC by torsten.eichstaedt
Modified: 2018-01-12 22:01 UTC (History)
2 users (show)

See Also:
clarkjc: maintainer-feedback+


Attachments
Auto-accept the Intel EULA (744 bytes, patch)
2016-02-01 00:14 UTC, John Clark
clarkjc: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description torsten.eichstaedt 2016-01-29 15:48:34 UTC
when updating via portmaster, the dialog to accept the Intel EULA license is hidden in the build log file that is automatically generated by portmaster.  Thus the license can not be accepted and the build stalls forever.

WORKAROUND: go to the ports directory in the ports tree, manually create the port's package and install it:
$ cd /usr/ports/sysutils/devcpu-data
$ sudo make package
$ cd work/pkg
$ sudo pkg add -f devcpu-data-1.6.txz

Then update any other ports as usual, e.g.

$ sudo portmaster --packages-build -a
Comment 1 John Clark 2016-02-01 00:14:55 UTC
Created attachment 166371 [details]
Auto-accept the Intel EULA
Comment 2 John Marino freebsd_committer 2016-02-10 18:47:17 UTC
PM has a new maintainer, reassign PR.
Comment 3 Torsten Zühlsdorff 2016-02-11 11:07:05 UTC
Hello,

How can i reproduce this bug? I get the dialog to accept the EULA while the update - even without the patch.

So does this bug still stands? If yes: which steps do i need to follow to reproduce it?

Greetings,
Torsten
Comment 4 John Clark 2016-02-12 02:30:55 UTC
(In reply to Torsten Zühlsdorff from comment #3)

Hello Torsten,

This is how I was able to reproduce the problem (or at least what I think the reporter of the bug is reporting):

1) pkg delete devcpu-data
2) cd /usr/ports/sysutils/devcpu-data
3) Edit Makefile and change PORTVERSION from 1.6 to 1.5
4) make install clean
5) Edit Makefile and change PORTVERSION back to 1.6
6) portmaster -H -a

Thanks.

John
Comment 5 Torsten Zühlsdorff 2016-02-26 13:50:09 UTC
Hello John,

thanks for the pointer. Which your description i could reproduce the problem.

But i am a little in doubt. The problem just occurs because of the "-H" flag, which clearly state "hide details of the port build and install in a log file". 

Accepting the EULA is part of the port build. 

So, yeah. I understand the problem but i'm not sure if this is solvable. I will have a deeper look at the code to figure this out.
Comment 6 Torsten Zühlsdorff 2016-02-26 13:55:04 UTC
Forgot to mention:

The patch "fix" this problem but simply auto-accepting the EULA. I can confirm, that the patch fixes the issue.

I could not say if auto-accepting is correct. But this isn't a portmaster issue. ;)
Comment 7 torsten.eichstaedt 2016-03-06 19:25:53 UTC
(In reply to Torsten Zühlsdorff from comment #6)
last update I tried was:
# portmaster --packages-build -a -x curl
i.e. w/o the -H flag.  The problem is that when I let portmaster do the update it hides many output in log files (which is usually good and not the error itself).  Maybe it shows /dev/stdout but redirects /dev/stderr to a log and the port writes the EULA acceptance dialog to stderr?  What's going wrong here is that other dialogs (of other ports) are shown on the console and not written to log files but the EULA dialog of dev/cpu-data goes to a log file.
Comment 8 Stefan Esser freebsd_committer 2018-01-10 20:02:16 UTC
I cannot reproduce the problem with the current portmaster version:

# portmaster -m LICENSES_ASK=yes sysutils/devcpu-data

displays the license text, allows to scroll down to the bottom and to accept or reject the license.

Please re-open this PR with sufficient detail to allow to reproduce it, if you think it is still relevant.
Comment 9 Stefan Esser freebsd_committer 2018-01-12 21:59:13 UTC
I have verified the problem if -H is passed.
A fix will be committed to portmaster, after testing.
Comment 10 commit-hook freebsd_committer 2018-01-12 22:00:20 UTC
A commit references this bug:

Author: se
Date: Fri Jan 12 21:59:51 UTC 2018
New revision: 458881
URL: https://svnweb.freebsd.org/changeset/ports/458881

Log:
  Fix display of license acceptance menu if build logs are hidden with -H.

  PR:		206738
  Reported by:	torsten.eichstaedt@web.de
  Approved by:	antoine (implicit)

Changes:
  head/ports-mgmt/portmaster/Makefile
  head/ports-mgmt/portmaster/files/patch-portmaster
Comment 11 Stefan Esser freebsd_committer 2018-01-12 22:01:48 UTC
Fixed in portmaster 3.18_13.