Bug 206794 - lang/ghc does not install with synth
Summary: lang/ghc does not install with synth
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Gabor Pali
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-31 14:01 UTC by Walter Schwarzenfeld
Modified: 2016-02-19 20:55 UTC (History)
3 users (show)

See Also:
pgj: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Walter Schwarzenfeld 2016-01-31 14:01:13 UTC
Lang/ghc does not install with synth. Error Message
===>  Building package for ghc-7.10.2
actual-package-depends: dependency on /lib/libutil.so.9 not registered (normal if it belongs to base)

In the port installs ,althrough this message.

The problem is here:
LIB_DEPENDS+=          libutil.so.9:${PORTSDIR}/misc/compat9x

The compat9x port has no libutil* file in its source.

If I comment this line, it works.

Either we can remove this line, or it is need to add the libutil file to the compat9x port.
Comment 1 Chris Hutchinson 2016-01-31 22:18:58 UTC
(In reply to Walter Schwarzenfeld from comment #0)
> Lang/ghc does not install with synth. Error Message
> ===>  Building package for ghc-7.10.2
> actual-package-depends: dependency on /lib/libutil.so.9 not registered
> (normal if it belongs to base)
> 
> In the port installs ,althrough this message.
> 
> The problem is here:
> LIB_DEPENDS+=          libutil.so.9:${PORTSDIR}/misc/compat9x
> 
> The compat9x port has no libutil* file in its source.
> 
> If I comment this line, it works.
> 
> Either we can remove this line, or it is need to add the libutil file to the
> compat9x port.

Hello, Walter. I think we discussed this on the FreeBSD forums.
I had no difficulty building this on my box, when
building/installing ports-mgmt/synth *but* I built a custom kernel
for this box, and KERNCONF includes the following:
options 	COMPAT_FREEBSD9
Interestingly, so does GENERIC. It's probably also worth noting;
I don't have misc/compat9x installed (why would I?).
FWIW I'm tracking -CURRENT. Are you on 10?

Just thought it all worth mentioning, in case any of it helps
track down the issue(s).

--Chris
Comment 2 Walter Schwarzenfeld 2016-02-01 00:30:47 UTC
I have 10.2-RELEASE amd64.
Comment 3 Gabor Pali freebsd_committer 2016-02-02 07:24:55 UTC
The dependency on misc/compat9x was introduced because the bootstrap compiler used in the compilation of lang/ghc was built for FreeBSD 9.x (to minimize the need for providing a separate bootstrap compiler for each major versions), so it could work on later systems safely.  However, I can accept that this might actually be redundant, and it is not needed.  I will investigate this.
Comment 4 John Marino freebsd_committer 2016-02-13 07:29:38 UTC
Hi Gabor,

I just checked the compat9x port pkg-plists and it doesn't even contain libutil (any version).

So it's not a case of the base library satisfying the requirement and thus compat9x doesn't come it, it's a case that the requirement cannot be satisfied by compat9x under any circumstance.

If you can confirm that I didn't overlook something silly, I think you'll have enough proof to remove the line.

Thanks,
John
Comment 5 Gabor Pali freebsd_committer 2016-02-13 08:20:04 UTC
Okay, I have checked that none of the following libraries, which might be used by the bootstrap compiler, present in misc/compat9x:

libc.so.7 
libcharset.so.1 
libiconv.so.2 
libm.so.5 
libncurses.so.8 
librt.so.1 
libthr.so.3 
libutil.so.9

That is, in conclusion, the dependency on misc/compat9x is indeed redundant, and it appears to be safe to remove.
Comment 6 John Marino freebsd_committer 2016-02-13 08:42:37 UTC
is haskell@ planning to make this change the port?
Comment 7 Gabor Pali freebsd_committer 2016-02-13 08:54:45 UTC
(In reply to John Marino from comment #6)

Yes.
Comment 8 commit-hook freebsd_committer 2016-02-19 20:26:10 UTC
A commit references this bug:

Author: pgj
Date: Fri Feb 19 20:25:34 UTC 2016
New revision: 409200
URL: https://svnweb.freebsd.org/changeset/ports/409200

Log:
  - Remove the superfluous dependency on misc/compat9x

  PR:		206794
  Submitted by:	Walter Schwarzenfeld <w.litter@aon.at>
  Obtained from:	FreeBSD Haskell

Changes:
  head/lang/ghc/Makefile
Comment 9 Gabor Pali freebsd_committer 2016-02-19 20:55:13 UTC
It has been now fixed.  Thank you for reporting this problem!