Bug 206811 - games/pioneer: Update to 20160225
Summary: games/pioneer: Update to 20160225
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Guido Falsi
URL:
Keywords: needs-patch, needs-qa
Depends on:
Blocks:
 
Reported: 2016-02-01 01:11 UTC by lightside
Modified: 2016-02-28 13:38 UTC (History)
1 user (show)

See Also:


Attachments
Proposed patch (since 402913 revision) (1.59 KB, patch)
2016-02-01 01:11 UTC, lightside
no flags Details | Diff
The poudriere testport log (FreeBSD 9.3 amd64) (18.81 KB, application/x-bzip2)
2016-02-01 01:12 UTC, lightside
no flags Details
Possible patch for armv6 architecture (untested) (396 bytes, patch)
2016-02-01 01:17 UTC, lightside
no flags Details | Diff
Proposed patch (since 402913 revision) (1.59 KB, patch)
2016-02-05 03:32 UTC, lightside
no flags Details | Diff
The poudriere testport log (FreeBSD 9.3 amd64) (18.80 KB, application/x-bzip2)
2016-02-05 03:50 UTC, lightside
no flags Details
Proposed patch (since 402913 revision) (1.59 KB, patch)
2016-02-12 19:02 UTC, lightside
no flags Details | Diff
Proposed patch (since 402913 revision) (1.59 KB, patch)
2016-02-15 17:57 UTC, lightside
no flags Details | Diff
The poudriere testport log (FreeBSD 10.2 amd64) (21.20 KB, application/x-bzip2)
2016-02-15 19:10 UTC, lightside
no flags Details
Proposed patch (since 402913 revision) (1.59 KB, patch)
2016-02-21 16:40 UTC, lightside
no flags Details | Diff
Proposed patch (since 402913 revision) (1.59 KB, patch)
2016-02-26 01:21 UTC, lightside
lightside: maintainer-approval+
Details | Diff
The poudriere testport log (FreeBSD 10.2 amd64) (20.95 KB, application/x-bzip2)
2016-02-26 02:05 UTC, lightside
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description lightside 2016-02-01 01:11:25 UTC
Created attachment 166373 [details]
Proposed patch (since 402913 revision)

Patch to update games/pioneer port from 20151130 to 20160129 version.

Look following link for changes:
https://github.com/pioneerspacesim/pioneer/compare/20151130...20160129

- Remove patch, which fixed by upstream

The build tested on FreeBSD 9.3 and 10.2 amd64.

The saved games from previous version is not compatible.
Comment 1 lightside 2016-02-01 01:12:14 UTC
Created attachment 166374 [details]
The poudriere testport log (FreeBSD 9.3 amd64)
Comment 2 lightside 2016-02-01 01:17:22 UTC
Created attachment 166375 [details]
Possible patch for armv6 architecture (untested)

I guess, there is a possibility to use GCC compiler on armv6 architecture to fix assimp's configure error, which showed on current PortsMon for 20151130 version:
http://beefy8.nyi.freebsd.org/data/head-armv6-default/p406714_s293048/logs/errors/pioneer-0.0.20151130.log

But I can't test this configuration on newer FreeBSD version for core dump(s), which I see on FreeBSD 10.2, when using GCC, instead of CLANG compiler.

The possible patch attached for armv6 architecture, if there are interested people to test it (build and run).
Comment 3 lightside 2016-02-05 03:32:31 UTC
Created attachment 166587 [details]
Proposed patch (since 402913 revision)

Updated to 20160205 version.

Look following link for changes:
https://github.com/pioneerspacesim/pioneer/compare/20151130...20160205
Comment 4 lightside 2016-02-05 03:50:16 UTC
Created attachment 166588 [details]
The poudriere testport log (FreeBSD 9.3 amd64)
Comment 5 lightside 2016-02-12 19:02:58 UTC
Created attachment 166904 [details]
Proposed patch (since 402913 revision)

Updated to 20160211 version.

Look following link for changes:
https://github.com/pioneerspacesim/pioneer/compare/20151130...20160211
Comment 6 lightside 2016-02-15 17:57:39 UTC
Created attachment 167039 [details]
Proposed patch (since 402913 revision)

Updated to 20160214 version.

Look following link for changes:
https://github.com/pioneerspacesim/pioneer/compare/20151130...20160214
Comment 7 lightside 2016-02-15 19:03:19 UTC
Comment on attachment 166375 [details]
Possible patch for armv6 architecture (untested)

The patch for armv6 architecture was added for interested people only and if there are none, then it's not mandatory to apply on this PR.
Comment 8 lightside 2016-02-15 19:10:31 UTC
Created attachment 167044 [details]
The poudriere testport log (FreeBSD 10.2 amd64)

(In reply to comment #2)
> But I can't test this configuration on newer FreeBSD version for core dump(s),
> which I see on FreeBSD 10.2, when using GCC, instead of CLANG compiler.

I need to note again, that this port was built and run ok, when using current (3.4.1) default CLANG compiler on FreeBSD 10.2.
Added poudriere testport log for FreeBSD 10.2 amd64, just in case.
Comment 9 lightside 2016-02-21 16:40:49 UTC
Created attachment 167262 [details]
Proposed patch (since 402913 revision)

Updated to 20160221 version:
https://github.com/pioneerspacesim/pioneer/compare/20151130...20160221
Comment 10 Guido Falsi freebsd_committer 2016-02-21 18:50:07 UTC
Hi,

Update looks good, I'm testing it.

I'm unable to test the arm patch though.

Would like me to commit it blindly(it's not going to break anything anyway), or rather let it rest until properly tested?
Comment 11 lightside 2016-02-21 21:24:47 UTC
Hello, Guido Falsi.

(In reply to comment #10)
> Update looks good, I'm testing it.

Thanks for your attention.

(In reply to comment #10)
> I'm unable to test the arm patch though.
> Would like me to commit it blindly(it's not going to break anything anyway),
> or rather let it rest until properly tested?

I'm not sure about this, because of no FreeBSD version restrictions for armv64 case. I experienced this kind of configure error on FreeBSD 9.3 amd64, which was solved by using GCC compiler, while here it was for head (11) version on armv64. It might be hard to decide when to switch from GCC to (default) Clang compiler, while the port may build fine with using GCC compiler, but possible core dumps, when running pioneer application.

I found following (simplified) test-case in pioneer's configure script, which caused mentioned configure error:
-8<--
// c++ -o conftest -I/usr/local/include -L/usr/local/lib -Wl,-rpath,/usr/local/lib -lassimp conftest.cpp

#include <assimp/defs.h>
#include <assimp/version.h>

int main () {
	if (aiGetVersionMajor() >= 3 && aiGetVersionMinor() >= 0)
		return 0;

	return 1;
}
-->8-

Perhaps, some ABI incompatibility between GCC compiled assimp library and (default) C++ armv64 compiler on FreeBSD head version. The 'Script "configure" failed unexpectedly' message in armv64 build log may be related to "core dump" also.

I guess, in case of default C++ compiler support on armv64, the patch for armv64 should not be applied (for testing purposes). But in case of possible working pioneer application on armv64 - it may be applied. This might depend from a response of FreeBSD armv64 user(s). Currently, I'm more for just an update without armv64 patch.
Comment 12 lightside 2016-02-21 21:41:57 UTC
(In reply to comment #11)
> armv64

The "armv6", of course. Sorry for mistake.
Comment 13 lightside 2016-02-21 22:24:08 UTC
(In reply to comment #10)

I just spotted some new fixes and performance improvements after today release version:
https://github.com/pioneerspacesim/pioneer/compare/20160221...884cee5af0

Is it possible to wait some days for next release version?
I may add a new patch to the PR, when next release version will be available.
Comment 14 Kubilay Kocak freebsd_committer freebsd_triage 2016-02-22 00:31:10 UTC
@lightside, if you'd like to put the issue 'on hold', the best way to currently do that is to obsolete all existing patches, and set needs-patch keyword, which I've done.
Comment 15 lightside 2016-02-22 02:36:29 UTC
Hello, Kubilay Kocak.

(In reply to comment #14)
> if you'd like to put the issue 'on hold', the best way to currently do that
> is to obsolete all existing patches, and set needs-patch keyword,
> which I've done.

Ok, I obsoleted the proposed patch, except untested one, in case there are interested people to test it.
Sorry about this situation. Usually, I try to find a best moment to do an port update near the end of the month, but sometimes some important source updates may come really fast, like in this situation. This application is in development.

I hope, there will be a next update, which is ready to commit.
Comment 16 Guido Falsi freebsd_committer 2016-02-22 09:36:11 UTC
(In reply to lightside from comment #11)

> I'm not sure about this, because of no FreeBSD version restrictions for
> armv64 case. I experienced this kind of configure error on FreeBSD 9.3
> amd64, which was solved by using GCC compiler, while here it was for head
> (11) version on armv64. It might be hard to decide when to switch from GCC
> to (default) Clang compiler, while the port may build fine with using GCC
> compiler, but possible core dumps, when running pioneer application.
> 
[...]

I'm sorry I'm unable to really comment on all this. You'll need to get someone with knowledge about compiler details for armv6.

For amd64 and i386, regarding C++ especially software using libc++/libstdc++, before 10.x the OS is configured to expect the gcc + libstdc++ chain, while after 10.0 release it's expected to use the clang + libc++ chain, that's what base system libraries are compiled against and most ports software too.

The discriminating __FreeBSD_version value already used in pioneer should be correct (1000054).

For ARM platforms the situation could be somewhat different. I know that arm moved to clang at a later date than amd64/i386, so the FreeBSD version number to use could be different, at least in theory the same stack should be used as in i386/amd64.

> 
> I guess, in case of default C++ compiler support on armv64, the patch for
> armv64 should not be applied (for testing purposes). But in case of possible
> working pioneer application on armv64 - it may be applied. This might depend
> from a response of FreeBSD armv64 user(s). Currently, I'm more for just an
> update without armv64 patch.

I'd agree, without testing it's impossible to know what's the correct fix.

I'll anyway wait your next patch before updating the port.
Comment 17 lightside 2016-02-26 01:21:31 UTC
Created attachment 167425 [details]
Proposed patch (since 402913 revision)

Updated to 20160225 version:
https://github.com/pioneerspacesim/pioneer/compare/20151130...20160225

Now it's ready to commit. Thanks in advance.
Comment 18 lightside 2016-02-26 02:05:39 UTC
Created attachment 167427 [details]
The poudriere testport log (FreeBSD 10.2 amd64)
Comment 19 commit-hook freebsd_committer 2016-02-28 10:19:43 UTC
A commit references this bug:

Author: madpilot
Date: Sun Feb 28 10:19:10 UTC 2016
New revision: 409733
URL: https://svnweb.freebsd.org/changeset/ports/409733

Log:
  - Update to 20160225

  Note that saved games from previous versions are not compatible.

  PR:		206811
  Submitted by:	lightside at gmx.com (maintainer)

Changes:
  head/games/pioneer/Makefile
  head/games/pioneer/distinfo
  head/games/pioneer/files/patch-src_posix_OSPosix.cpp
Comment 20 Guido Falsi freebsd_committer 2016-02-28 10:23:31 UTC
Committed!

I'm closing this bug report because the main patch is committed.

Could you file again the proposed ARM patch in it's own bug so it does not get lost until some testing with it can be performed?

Thanks.
Comment 21 lightside 2016-02-28 13:38:32 UTC
(In reply to comment #20)
> Committed!
Thanks for commit.

(In reply to comment #20)
> Could you file again the proposed ARM patch in it's own bug so it does not
> get lost until some testing with it can be performed?
Yes, of course. I created a bug 207559 for it.