Bug 206816 - mail/opensmtpd: SIGSEGV with (signal 11) with openssl 1.0.2f
Summary: mail/opensmtpd: SIGSEGV with (signal 11) with openssl 1.0.2f
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Many People
Assignee: Pietro Cerutti
URL: https://lists.freebsd.org/pipermail/f...
Keywords: crash, needs-qa
Depends on:
Blocks:
 
Reported: 2016-02-01 11:10 UTC by Alexander
Modified: 2016-02-02 16:01 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (ashish)
koobs: merge-quarterly?


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander 2016-02-01 11:10:53 UTC
Hello.

opensmtpd-5.7.3,1 failed to start and generates SIGSEGV if openssl 1.0.2f installed (FreeBSD 10.2).
# freebsd-version
10.2-RELEASE-p11
# tail -f /var/log/messages 
Feb  1 13:43:25 hostanme kernel: pid 45993 (smtpd), uid 257: exited on signal 11
Feb  1 13:43:25 hostanme smtpd[45991]: warn: lka -> pony: pipe closed
Feb  1 13:43:25 hostanme smtpd[45989]: warn: queue -> pony: pipe closed
Feb  1 13:43:25 hostanme smtpd[45990]: warn: control -> pony: pipe closed
Feb  1 13:43:25 hostanme smtpd[45994]: warn: ca -> pony: pipe closed
Feb  1 13:43:25 hostanme smtpd[45992]: warn: scheduler -> queue: pipe closed
# tail -f /var/log/maillog 
Feb  1 13:43:25 rgt002sm smtpd[45987]: info: OpenSMTPD 5.7.3p1 starting
Feb  1 13:43:25 rgt002sm smtpd[45988]: info: startup
Feb  1 13:43:25 rgt002sm smtpd[45993]: smtp-out: session 9413ee0d079a5b8e: connecting to tls://132.245.67.82:587 (132.245.67.82)
Feb  1 13:43:25 rgt002sm smtpd[45988]: warn: parent -> pony: pipe closed
Feb  1 13:43:25 rgt002sm smtpd[45991]: warn: lka -> pony: pipe closed
Feb  1 13:43:25 rgt002sm smtpd[45989]: warn: queue -> pony: pipe closed
Feb  1 13:43:25 rgt002sm smtpd[45990]: warn: control -> pony: pipe closed
Feb  1 13:43:25 rgt002sm smtpd[45994]: warn: ca -> pony: pipe closed
Feb  1 13:43:25 rgt002sm smtpd[45992]: warn: scheduler -> queue: pipe closed

Steps to reproduce:
1. portsnap fetch extract update
2. Install opensmtpd from ports repository (openssl 1.0.2f will be installed automatically because of dependences).
3. Configure opensmtpd. 
4. Start opensmtpd. opensmtpd fails at this step.

P.S. There is no problem running opensmtpd with openssl 1.0.2e
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2016-02-01 11:27:21 UTC
Known issue (See: URL) and upstream issue (See: See Also)
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2016-02-01 11:30:02 UTC
CC freebsd-ports thread participants
Comment 3 Pietro Cerutti freebsd_committer 2016-02-02 13:17:42 UTC
I'm in touch with upstream. I'll take care of this one.
Comment 4 commit-hook freebsd_committer 2016-02-02 15:36:36 UTC
A commit references this bug:

Author: gahr
Date: Tue Feb  2 15:36:12 UTC 2016
New revision: 407825
URL: https://svnweb.freebsd.org/changeset/ports/407825

Log:
  mail/opensmtpd: update to 5.7.3p2

  Details at https://github.com/OpenSMTPD/OpenSMTPD/issues/650

  While at it, remove a stale patch that isn't applicable anymore. Upstream
  implements this logic already, and the patch doesn't actually patch anything.

  PR:				206816
  Submitted by:	sa.inbox@gmail.com
  Approved by:	portmgr@

Changes:
  head/mail/opensmtpd/Makefile
  head/mail/opensmtpd/distinfo
  head/mail/opensmtpd/files/patch-mk_smtpd_Makefile.in
Comment 5 commit-hook freebsd_committer 2016-02-02 16:01:38 UTC
A commit references this bug:

Author: gahr
Date: Tue Feb  2 16:01:17 UTC 2016
New revision: 407827
URL: https://svnweb.freebsd.org/changeset/ports/407827

Log:
  MFH: r407825

  mail/opensmtpd: update to 5.7.3p2

  Details at https://github.com/OpenSMTPD/OpenSMTPD/issues/650

  While at it, remove a stale patch that isn't applicable anymore. Upstream
  implements this logic already, and the patch doesn't actually patch anything.

  PR:				206816
  Submitted by:	sa.inbox@gmail.com
  Approved by:	portmgr@ (bapt)

Changes:
_U  branches/2016Q1/
  branches/2016Q1/mail/opensmtpd/Makefile
  branches/2016Q1/mail/opensmtpd/distinfo
  branches/2016Q1/mail/opensmtpd/files/patch-mk_smtpd_Makefile.in