Bug 206843 - devel/pep8: Update to 1.7.0 (Fixes breakage of devel/py-flake8)
Summary: devel/pep8: Update to 1.7.0 (Fixes breakage of devel/py-flake8)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Sofian Brabez
URL:
Keywords: needs-qa, patch, regression
Depends on:
Blocks:
 
Reported: 2016-02-02 11:31 UTC by Davide D'Amico
Modified: 2016-02-17 11:03 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (sbz)
koobs: maintainer-feedback? (wg)
koobs: merge-quarterly?


Attachments
Patch against devel/pep8 directory to upgrade it to 1.7.0 (850 bytes, patch)
2016-02-02 11:31 UTC, Davide D'Amico
no flags Details | Diff
Error reported by flake8 if pep8-1.6.2 is installed. (1.27 KB, text/plain)
2016-02-02 11:40 UTC, Davide D'Amico
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Davide D'Amico 2016-02-02 11:31:45 UTC
Created attachment 166428 [details]
Patch against devel/pep8 directory to upgrade it to 1.7.0

devel/flake8 is complaining because the version installed of devel/pep8 is not supported. Upgrading devel/pep8 to 1.7.0 seems trivial (please find attached a patch): tested flake8 after that, it works correctly.
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2016-02-02 11:35:57 UTC
Thank you for your report Davide

Can you include (as an attachment) the error you are seeing please, with as much context (build-time? run-time?) as possible
Comment 2 Davide D'Amico 2016-02-02 11:40:40 UTC
Created attachment 166429 [details]
Error reported by flake8 if pep8-1.6.2 is installed.
Comment 3 Davide D'Amico 2016-02-02 11:41:32 UTC
Error attached. It's a runtime error; basically flake8 finds installed an unsupported pep8 version and it fails.
Comment 4 Davide D'Amico 2016-02-12 15:51:52 UTC
Hi,
any update on this?

Thanks,
d.
Comment 5 commit-hook freebsd_committer 2016-02-17 10:59:20 UTC
A commit references this bug:

Author: sbz
Date: Wed Feb 17 10:58:35 UTC 2016
New revision: 409035
URL: https://svnweb.freebsd.org/changeset/ports/409035

Log:
  - Update to 1.7.0

  PR:		206843
  Submitted by:	Davide D'Amico <davide.damico at gmail.com>

Changes:
  head/devel/pep8/Makefile
  head/devel/pep8/distinfo
Comment 6 Sofian Brabez freebsd_committer 2016-02-17 11:03:10 UTC
Committed in r409035. Thank you for your report!