Bug 206945 - multimedia/avidemux-plugins fails to detect x265
Summary: multimedia/avidemux-plugins fails to detect x265
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Thomas Zander
URL:
Keywords: needs-qa, patch-ready
Depends on:
Blocks:
 
Reported: 2016-02-05 07:34 UTC by Mikhail Teterin
Modified: 2016-02-14 17:07 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (multimedia)
riggs: merge-quarterly+


Attachments
Do not add -ldl to the list of libraries (494 bytes, patch)
2016-02-05 07:34 UTC, Mikhail Teterin
no flags Details | Diff
Revised patch addressing the plist issues as well (3.82 KB, patch)
2016-02-07 14:16 UTC, Thomas Zander
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mikhail Teterin freebsd_committer 2016-02-05 07:34:30 UTC
Created attachment 166606 [details]
Do not add -ldl to the list of libraries

Without the attached patch in avidemux/files the cmake for avidemux-plugins fails to detect x265 -- because it attempts to link with the non-existent libdl (see Bug 206864, comment 17).

With this patch the x265 is properly found, although check-plist still fails:

Error: Orphaned: lib/ADM_plugins6/audioDecoder/libADM_ad_opus.so
Error: Orphaned: lib/ADM_plugins6/audioEncoders/libADM_ae_twolame.so
Error: Orphaned: lib/ADM_plugins6/videoFilters/libADM_vf_ssa.so
Comment 1 Thomas Zander freebsd_committer 2016-02-07 14:16:58 UTC
Created attachment 166707 [details]
Revised patch addressing the plist issues as well

Revised patch based on Mikhail's patch.

Adds OPTIONs for the discovered dependencies and adapts plist generation based on those.
Comment 2 Thomas Zander freebsd_committer 2016-02-07 14:18:51 UTC
(In reply to Mikhail Teterin from comment #0)

Mikhail, I have added a new svn patch (relative to ${PORTSDIR}/multimedia). Could you check whether this resolves the issues for you?
Comment 3 Thomas Zander freebsd_committer 2016-02-13 12:33:52 UTC
Mikhail, did you get a chance to check whether the plist fixes of my last patch work for you?
Comment 4 Mikhail T. 2016-02-13 17:58:55 UTC
(In reply to Thomas Zander from comment #3)
> did you get a chance to check whether the plist fixes of my
> last patch work for you?

Sorry, I didn't. I had a feeling, that the orphans were due to things I happened to have installed on my machine -- which got enabled by configure unexpectedly...

To investigate properly would've required more time than I had this week. But, if, Monsieur Antoine still keeps as tight a watch on package-violations as he did during the ports r398381 and ports r398402, you would've heard from him by now, if your port was in way a violator...
Comment 5 Thomas Zander freebsd_committer 2016-02-13 18:13:28 UTC
(In reply to Mikhail T. from comment #4)

You are definitely right, the orphans came from local packages that you have installed.
On the pkg build cluster this does not pose problems since pkg builds happen in a clean environment where only the minimum set of packages are installed and no libs are picked up accidentally.

In any case, I could reproduce the issue at least for the dependencies that you mentioned, and we have a solution for it. If there are more, we'll eventually find out.
Comment 6 commit-hook freebsd_committer 2016-02-14 07:44:05 UTC
A commit references this bug:

Author: riggs
Date: Sun Feb 14 07:43:41 UTC 2016
New revision: 408848
URL: https://svnweb.freebsd.org/changeset/ports/408848

Log:
  Fix dependencies: x265, opus, twolame, fribidi

  x265 was not correctly detected due to link attempt to libdl.
  Also avidemux now automatically detects the presence of opus,
  twolame and fribidi during configure and builds additional
  plugins for them.
  This changeset introduces new OPTIONS FRIBIDI OPUS TWOLAME
  (all non-default) and fixes plugins pkg-plist.
  Bump PORTREVISION for avidemux-*

  PR:		206945
  Submitted by:	mi
  Reviewed by:	riggs
  MFH:		2016Q1

Changes:
  head/multimedia/avidemux/Makefile.common
  head/multimedia/avidemux/files/patch-cmake_admCheckX265.cmake
  head/multimedia/avidemux-plugins/pkg-plist
Comment 7 commit-hook freebsd_committer 2016-02-14 17:06:42 UTC
A commit references this bug:

Author: riggs
Date: Sun Feb 14 17:06:13 UTC 2016
New revision: 408870
URL: https://svnweb.freebsd.org/changeset/ports/408870

Log:
  MFH: r408848

  Fix dependencies: x265, opus, twolame, fribidi

  x265 was not correctly detected due to link attempt to libdl.
  Also avidemux now automatically detects the presence of opus,
  twolame and fribidi during configure and builds additional
  plugins for them.
  This changeset introduces new OPTIONS FRIBIDI OPUS TWOLAME
  (all non-default) and fixes plugins pkg-plist.
  Bump PORTREVISION for avidemux-*

  PR:		206945
  Submitted by:	mi
  Reviewed by:	riggs
  Approved by:	ports-secteam (feld)

Changes:
_U  branches/2016Q1/
  branches/2016Q1/multimedia/avidemux/Makefile.common
  branches/2016Q1/multimedia/avidemux/files/patch-cmake_admCheckX265.cmake
  branches/2016Q1/multimedia/avidemux-plugins/pkg-plist