Bug 206979 - security/govpn: Update to 5.6
Summary: security/govpn: Update to 5.6
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Raphael Kubo da Costa
URL:
Keywords: easy, needs-qa, patch
Depends on:
Blocks:
 
Reported: 2016-02-06 15:26 UTC by Sergey Matveev
Modified: 2016-02-12 16:50 UTC (History)
1 user (show)

See Also:
rakuco: merge-quarterly-


Attachments
Update patch from 5.4 -> 5.5 (771 bytes, patch)
2016-02-06 15:26 UTC, Sergey Matveev
koobs: maintainer-approval+
Details | Diff
5.4 -> 5.6 update patch (771 bytes, patch)
2016-02-12 08:20 UTC, Sergey Matveev
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sergey Matveev 2016-02-06 15:26:04 UTC
Created attachment 166663 [details]
Update patch from 5.4 -> 5.5

Update GoVPN to 5.5. Fixed workability issues on 32-bit platforms.
Comment 1 Raphael Kubo da Costa freebsd_committer 2016-02-11 22:31:43 UTC
Hi,

The update fails to build on Poudriere here.

On HEAD-amd64:
=======================<phase: stage          >============================
===>  Staging for govpn-5.5
===>   govpn-5.5 depends on executable: indexinfo - found
===>   Generating temporary packing list
/usr/bin/make -C doc
makeinfo index.texi
make[2]: exec(makeinfo) failed (No such file or directory)
*** Error code 1

On 9.3-i386:
=======================<phase: stage          >============================
===>  Staging for govpn-5.5
===>   govpn-5.5 depends on executable: indexinfo - found
===>   Generating temporary packing list
/usr/bin/make -C doc
makeinfo index.texi
index.texi:3: warning: unrecognized encoding name `UTF-8'.
/wrkdirs/usr/ports/security/govpn/work/govpn-5.5/doc//news.ru.texi:243: `Релиз 1.0' has no Up field (perhaps incorrect sectioning?).
[lots of output]
makeinfo: Removing output file `index.info' due to errors; use --force to preserve.
*** [govpn.info] Error code 1

Stop in /wrkdirs/usr/ports/security/govpn/work/govpn-5.5/doc.
*** [doc] Error code 1
Comment 2 Sergey Matveev 2016-02-12 08:20:28 UTC
Created attachment 166887 [details]
5.4 -> 5.6 update patch
Comment 3 Sergey Matveev 2016-02-12 08:21:36 UTC
(In reply to Raphael Kubo da Costa from comment #1)
My fault! I fixed it in 5.6 release. So patch is for 5.4 to 5.6 transition.
Comment 4 commit-hook freebsd_committer 2016-02-12 09:42:46 UTC
A commit references this bug:

Author: rakuco
Date: Fri Feb 12 09:41:51 UTC 2016
New revision: 408709
URL: https://svnweb.freebsd.org/changeset/ports/408709

Log:
  Update to 5.6.

  v5.6:
  - Added up/down example script for replacing default route (thanks to Zhuoyun
    Wei).
  - Fixed documentation bug: .info was not installing.

  v5.5:
  - Ability to work on 32-bit platforms. sync/atomic library has some specific
    issues that caused panics on previous versions.

  PR:		206979
  Submitted by:	Sergey Matveev <stargrave@stargrave.org> (maintainer)

Changes:
  head/security/govpn/Makefile
  head/security/govpn/distinfo
Comment 5 Raphael Kubo da Costa freebsd_committer 2016-02-12 09:43:44 UTC
Committed, thank you for the update.

Since 5.5 apparently fixes govpn on 32-bit platforms, I guess it'd be good to MFH this commit to the 2016Q1 branch?
Comment 6 Sergey Matveev 2016-02-12 15:36:24 UTC
I am not sure I clearly understand your question, but if GoVPN should be commited with smaller delays, then yes, it would be better.
Comment 7 Raphael Kubo da Costa freebsd_committer 2016-02-12 16:04:27 UTC
No, I'm talking about cherry-picking my commit (ports r408709) to the 2016Q1 branch (https://svnweb.freebsd.org/ports/branches/2016Q1), which was branched off head in early January and receives bug and security fixes during the first quarter of 2016. See https://wiki.freebsd.org/Quarterly_Branch for more information.

In general, a port update like this wouldn't qualify as a merge candidate, but since you mentioned that the 5.5 update makes the port work on 32-bit platforms where it previously did not, I'd like to confirm with you that this is really the case so I can merge my commit to the 2016Q1 branch.
Comment 8 Sergey Matveev 2016-02-12 16:10:36 UTC
Ah, I see. Yes, I confirm that. Actually seems that noone before tested it on 32-bit platforms and at least several latest versions were broken. Now it works without any issues -- I use it everyday for the two weeks on 32 and 64 bit platforms.
Comment 9 Sergey Matveev 2016-02-12 16:11:12 UTC
Thank you for that!
Comment 10 Raphael Kubo da Costa freebsd_committer 2016-02-12 16:49:32 UTC
Hmm, merging is not trivial because the version in the 2016Q1 branch is still 4.2. Moving directly to 5.6 would be a big leap, so I'd rather play it safe and leave 5.6 only in head.
Comment 11 Raphael Kubo da Costa freebsd_committer 2016-02-12 16:50:11 UTC
Since the update has been committed to head and won't be backported to the 2016Q1 branch, we can finally close this bug. Thanks a lot!