Bug 207036 - [NEW PORT] devel/py3-nose: variant of devel/py-nose for Python 3.x
Summary: [NEW PORT] devel/py3-nose: variant of devel/py-nose for Python 3.x
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Ben Woods
URL: https://reviews.freebsd.org/D6280
Keywords:
Depends on:
Blocks: 207039
  Show dependency treegraph
 
Reported: 2016-02-08 23:12 UTC by Ben Woods
Modified: 2016-05-18 16:51 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (koobs)


Attachments
Patch to update devel/py3-nose (after svn copy) (1.60 KB, patch)
2016-02-08 23:15 UTC, Ben Woods
no flags Details | Diff
QA: Successful poudriere testport logs for devel/py3-nose on FreeBSD 10.2 amd64 (33.66 KB, text/plain)
2016-02-08 23:16 UTC, Ben Woods
no flags Details
Patch to create devel/py3-nose (using devel/py-nose as MASTERDIR) (1.40 KB, patch)
2016-02-21 11:56 UTC, Ben Woods
no flags Details | Diff
QA: Successful poudriere testport logs for devel/py3-nose on FreeBSD 10.2 amd64 (33.83 KB, text/plain)
2016-02-21 11:56 UTC, Ben Woods
no flags Details
Patch to create devel/py3-nose (using devel/py-nose as MASTERDIR) (1.66 KB, patch)
2016-02-21 19:06 UTC, Ben Woods
woodsb02: maintainer-approval? (koobs)
Details | Diff
QA: Successful poudriere testport logs for devel/py3-nose on FreeBSD 10.2 amd64 (33.28 KB, text/plain)
2016-02-21 19:11 UTC, Ben Woods
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Woods freebsd_committer 2016-02-08 23:12:34 UTC
* Copy devel/py-nose: svn copy devel/py-nose devel/py3-nose
 * Update to USES=python:3
 * Remove .if ${PYTHON_REL} >= 3000, since it is mandated by USES=python:3
 * Take maintainership - happy to either do this myself or leave with koobs@FreeBSD.org if they prefer
Comment 1 Ben Woods freebsd_committer 2016-02-08 23:14:09 UTC
This new port is required to fulfill the Python 3.2+ dependencies of the latest upstream version of science/gramps.

science/gramps depends on graphics/py3-pygraphviz, which in turn depends on devel/py3-nose.
Comment 2 Ben Woods freebsd_committer 2016-02-08 23:15:02 UTC
Created attachment 166769 [details]
Patch to update devel/py3-nose (after svn copy)

This patch should be applied after performing the following command:
svn copy devel/py-nose devel/py3-nose
svn patch <insertpatch>
Comment 3 Ben Woods freebsd_committer 2016-02-08 23:16:03 UTC
Created attachment 166770 [details]
QA: Successful poudriere testport logs for devel/py3-nose on FreeBSD 10.2 amd64
Comment 4 Ben Woods freebsd_committer 2016-02-21 11:56:31 UTC
Created attachment 167243 [details]
Patch to create devel/py3-nose (using devel/py-nose as MASTERDIR)

This patch changes the approach for the new port devel/py3-nose to use the existing port devel/py-nose as the MASTERDIR.

* Create new port devel/py3-nose
* Update index devel/Makefile
* Ensure devel/py-nose does not clobber USES variable in slave devel/py3-nose
Comment 5 Ben Woods freebsd_committer 2016-02-21 11:56:59 UTC
Created attachment 167244 [details]
QA: Successful poudriere testport logs for devel/py3-nose on FreeBSD 10.2 amd64
Comment 6 Ben Woods freebsd_committer 2016-02-21 19:06:19 UTC
Created attachment 167268 [details]
Patch to create devel/py3-nose (using devel/py-nose as MASTERDIR)

This updated patch corrects the versions of Python 3.x supported by devel/py3-nose; it is limited to 3.1-3.4. Python 3.5 may be available in the next release. [1]
This updated patch also fixes the regression-test target.

* Create new port devel/py3-nose
* Update index devel/Makefile
* Ensure devel/py-nose does not clobber USES variable in slave devel/py3-nose
* Fix target regression-test to use selftest.py [2]

 [1] https://github.com/nose-devs/nose/pull/983
 [2] https://github.com/nose-devs/nose/issues/400
Comment 7 Ben Woods freebsd_committer 2016-02-21 19:11:14 UTC
Created attachment 167269 [details]
QA: Successful poudriere testport logs for devel/py3-nose on FreeBSD 10.2 amd64
Comment 8 Ben Woods freebsd_committer 2016-05-09 21:44:59 UTC
Diff added to phabricator for review:
  https://reviews.freebsd.org/D6280
Comment 9 Ben Woods freebsd_committer 2016-05-10 08:37:02 UTC
koobs, I will take this bug report, but only commit it once you have given a positive review on phabricator.
Comment 10 commit-hook freebsd_committer 2016-05-18 16:50:35 UTC
A commit references this bug:

Author: woodsb02
Date: Wed May 18 16:50:21 UTC 2016
New revision: 415456
URL: https://svnweb.freebsd.org/changeset/ports/415456

Log:
  Create new port devel/py3-nose:
  - This is a variant of devel/py-nose for Python 3.x.
    A separate port is needed until the ports tree gets VARIANTS support.
    The science/gramps port will soon be updated to a version which only
    supports python3, and it depends on py-nose with python3.
    To allow people to only use packages directly (and not ports),
    the package building infrastructure needs to build 2 packages:
    py-nose with python2 and py-nose with python3.
    Since the ports tree doesn't yet have VARIANTS support, this is not
    yet possible without making a separate py3-nose port.
  - Ensure devel/py-nose does not clobber USES variable in slave devel/py3-nose
  - Fix devel/py-nose target regression-test to use selftest.py [1]

    [1] https://github.com/nose-devs/nose/issues/400

  PR:		207036
  Reviewed by:	mat (mentor)
  Approved by:	adamw (mentor), koobs (maintainer)
  Differential Revision:	https://reviews.freebsd.org/D6280

Changes:
  head/devel/Makefile
  head/devel/py-nose/Makefile
  head/devel/py3-nose/
  head/devel/py3-nose/Makefile