Bug 207057 - net-mgmt/observium: fix with rrdtool 1.5+
Summary: net-mgmt/observium: fix with rrdtool 1.5+
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Niclas Zeising
URL: http://comments.gmane.org/gmane.netwo...
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-09 13:44 UTC by Mathieu Arnold
Modified: 2016-02-09 22:28 UTC (History)
2 users (show)

See Also:
dirkx: maintainer-feedback+


Attachments
patch (2.02 KB, patch)
2016-02-09 13:44 UTC, Mathieu Arnold
no flags Details | Diff
further minor cleanups (4.25 KB, patch)
2016-02-09 20:33 UTC, dirkx
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mathieu Arnold freebsd_committer 2016-02-09 13:44:03 UTC
Created attachment 166799 [details]
patch

Some aggregated graphs rrd commands get created a way rrdtool 1.5 does not like.

The attached patch fixes it.

The issue is similar with the one described in the URL field.
Comment 1 dirkx 2016-02-09 20:33:48 UTC
Created attachment 166814 [details]
further minor cleanups

Above patch and a few portlint inspired further cleanups. Removed obsolete tests; added one extra dependency found.
Comment 2 dirkx 2016-02-09 20:36:10 UTC
Mathieu -- Thanks - that fixes it indeed!
Comment 3 Niclas Zeising freebsd_committer 2016-02-09 20:56:00 UTC
Grab
Comment 4 commit-hook freebsd_committer 2016-02-09 22:28:03 UTC
A commit references this bug:

Author: zeising
Date: Tue Feb  9 22:27:54 UTC 2016
New revision: 408601
URL: https://svnweb.freebsd.org/changeset/ports/408601

Log:
  Fix when using rrdtool 1.5+
  Pet portlint, add missing dependency.

  PR:		207057
  Submitted by:	Mathieu Arnold
  Approved by:	maintainer

Changes:
  head/net-mgmt/observium/Makefile
  head/net-mgmt/observium/files/patch-html_includes_graphs_generic__multi__bits__separated.inc.php
  head/net-mgmt/observium/files/pkg-message.in