Bug 207133 - [MAINTAINER] sysutils/htop: Fix process memory calculation
Summary: [MAINTAINER] sysutils/htop: Fix process memory calculation
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Cy Schubert
URL:
Keywords:
: 207132 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-02-12 16:59 UTC by Hung-Yi Chen
Modified: 2016-02-12 20:40 UTC (History)
1 user (show)

See Also:


Attachments
sysutils__htop.diff (2.94 KB, patch)
2016-02-12 16:59 UTC, Hung-Yi Chen
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Hung-Yi Chen 2016-02-12 16:59:41 UTC
Created attachment 166902 [details]
sysutils__htop.diff

* Fix process memory calculation
* Add FreeBSD battery support
* Add SHEBANG_LANG & SHEBANG_FILES
Comment 1 Cy Schubert freebsd_committer 2016-02-12 20:10:10 UTC
*** Bug 207132 has been marked as a duplicate of this bug. ***
Comment 2 commit-hook freebsd_committer 2016-02-12 20:40:08 UTC
A commit references this bug:

Author: cy
Date: Fri Feb 12 20:39:57 UTC 2016
New revision: 408755
URL: https://svnweb.freebsd.org/changeset/ports/408755

Log:
  * Fix process memory calculation
  * Add FreeBSD battery support
  * Add SHEBANG_LANG & SHEBANG_FILES

  PR:		207133
  Submitted by:	Hung-Yi Chen <gaod@hychen.org> (maintainer)

Changes:
  head/sysutils/htop/Makefile
  head/sysutils/htop/files/
  head/sysutils/htop/files/patch-freebsd__Battery.c
  head/sysutils/htop/files/patch-freebsd__FreeBSDProcessList.c
Comment 3 Cy Schubert freebsd_committer 2016-02-12 20:40:59 UTC
Committed. Thanks for the patch.