Bug 207144 - multimedia/gstreamer1-qt4: fix build with boost 1.60
Summary: multimedia/gstreamer1-qt4: fix build with boost 1.60
Status: Closed Works As Intended
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: kde
URL:
Keywords:
Depends on:
Blocks: 199601
  Show dependency treegraph
 
Reported: 2016-02-13 01:27 UTC by Dmitry Marakasov
Modified: 2016-03-25 10:36 UTC (History)
1 user (show)

See Also:
rakuco: maintainer-feedback+


Attachments
Patch (4.21 KB, patch)
2016-02-13 01:27 UTC, Dmitry Marakasov
rakuco: maintainer-approval-
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Marakasov freebsd_committer 2016-02-13 01:27:53 UTC
Created attachment 166920 [details]
Patch

- Fix build with boost 1.60
- Silence post-patch

see
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=199601
https://wiki.freebsd.org/BoostPortingProject/1.55-to-1.60
Comment 1 Raphael Kubo da Costa freebsd_committer 2016-02-15 00:13:26 UTC
I've proposed a different approach in https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=199601#c49 that does not require changing any Qt4-based port other than qt4-moc itself.
Comment 2 Raphael Kubo da Costa freebsd_committer 2016-02-15 00:14:39 UTC
Comment on attachment 166920 [details]
Patch

Setting maintainer-approval to '-' because at the very least the change to Makefile is unrelated.

In addition to that, I'd like some feedback to the approach I proposed in https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=199601#c49 that may solve the problem without requiring patching this port.
Comment 3 Don Lewis freebsd_committer 2016-03-24 22:44:20 UTC
Is this fixed by r411765 (or at least removed as a blocker for 199601?
Comment 4 Raphael Kubo da Costa freebsd_committer 2016-03-24 23:10:45 UTC
I haven't tested this with Boost 1.60 lately, but I believe ports r411765 should fix it indeed.
Comment 5 Dmitry Marakasov freebsd_committer 2016-03-25 10:36:11 UTC
I should've. I've tested moc patch wchich was committed with removal of patches which were removed and it built fine.