Bug 207200 - Page Fault - Fatal Trap 12
Summary: Page Fault - Fatal Trap 12
Status: Closed Unable to Reproduce
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 10.2-RELEASE
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-net mailing list
URL:
Keywords: IntelNetworking
Depends on:
Blocks:
 
Reported: 2016-02-15 02:12 UTC by kayasaman
Modified: 2018-12-20 19:15 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kayasaman 2016-02-15 02:12:56 UTC
Hi,

I've got a SuperMicro server:

CPU: Intel(R) Xeon(R) CPU E5-1620 v2 @ 3.70GHz (3700.08-MHz K8-class CPU)
Ram: 8GB
System Board: SM X9SRE

I'm running FreeBSD 10.2:

10.2-RELEASE FreeBSD 10.2-RELEASE #0 r286666: Wed Aug 12 15:26:37 UTC 2015


I keep running into this issue which arises after either rebooting or restarting NFSD:

Fatal trap 12: page fault while in kernel mode
cpuid = 1; apic id = 02
fault virtual address    = 0x378
fault code        = supervisor read data, page not present
instruction pointer    = 0x20:0xffffffff8092e980
stack pointer            = 0x28:0xfffffe0233eb4400
frame pointer            = 0x28:0xfffffe0233eb4480
code segment        = base rx0, limit 0xfffff, type 0x1b
            = DPL 0, pres 1, long 1, def32 0, gran 1
processor eflags    = interrupt enabled, resume, IOPL = 0
current process        = 12 (irq293: igb5:que 1)
trap number        = 12
panic: page fault
cpuid = 1
KDB: stack backtrace:
#0 0xffffffff80984e30 at kdb_backtrace+0x60
#1 0xffffffff809489e6 at vpanic+0x126
#2 0xffffffff809488b3 at panic+0x43
#3 0xffffffff80d4aadb at trap_fatal+0x36b
#4 0xffffffff80d4addd at trap_pfault+0x2ed
#5 0xffffffff80d4a47a at trap+0x47a
#6 0xffffffff80d307f2 at calltrap+0x8
#7 0xffffffff80b4a725 at xprt_active+0x45
#8 0xffffffff80b4e0a5 at svc_vc_soupcall+0x35
#9 0xffffffff809bcc52 at sowakeup+0x82
#10 0xffffffff80aea942 at tcp_do_segment+0x2b22
#11 0xffffffff80ae7720 at tcp_input+0x12b0
#12 0xffffffff80a77f57 at ip_input+0x97
#13 0xffffffff80a177d2 at netisr_dispatch_src+0x62
#14 0xffffffff80a0eb76 at ether_demux+0x126
#15 0xffffffff80a0f81e at ether_nh_input+0x35e
#16 0xffffffff80a177d2 at netisr_dispatch_src+0x62
#17 0xffffffff804f715c at igb_rxeof+0x60c
Uptime: 7m19s
Dumping 1671 out of 8129 MB:..1%..11%..21%..31%..41%..51%..61%..71%..81%..91%


The closest thing I could come up with is this:

https://forums.freebsd.org/threads/fatal-trap-12-page-fault-while-in-kernel-mode-on-new-server-running-freebsd-10-1-release-p10.51737/


According to the link the bug: Bug 194525 was fixed in an earlier version......?


Basically since the "Current Process" mentioned was the queue on igb5, I run a lagg0 interface with LACP and currently have 4 NIC's within the aggregation {igb2 through 5} connected to a Cisco switch running EtherChannel.

On some occasions it seems that igb5 starts flapping too, according to the system logs; not sure if that's related to the issue or not?

If I need to post any more information please advise!!


Thanks.
Comment 1 Hiren Panchasara freebsd_committer 2017-01-06 00:20:03 UTC
Can you reprod the problem? Seems like NFS and igb(4) are involved.
Comment 2 Eric Joyner freebsd_committer 2018-12-19 00:27:27 UTC
Do you still encounter this problem on FreeBSD 11.2 or 12.0?
Comment 3 kayasaman 2018-12-20 19:14:23 UTC
Hi, I have updated to 12.0-RELEASE now and things are ok regarding this.

I also hiked the system up to 24GB RAM too.

There are are other major issues but not regarding this bug.