Bug 207242 - urtw0: could not allocate USB transfers, err=USB_ERR_NO_PIPE (FreeBSD 10.2-RELEASE)
Summary: urtw0: could not allocate USB transfers, err=USB_ERR_NO_PIPE (FreeBSD 10.2-RE...
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: wireless (show other bugs)
Version: 10.2-RELEASE
Hardware: i386 Any
: --- Affects Some People
Assignee: freebsd-wireless (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-16 09:48 UTC by pnixte
Modified: 2016-10-25 08:51 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pnixte 2016-02-16 09:48:20 UTC
Hey all!

I can't seem to get an RTL8187B-chipset USB dongle (802.11 b/g) to work
under FreeBSD 10.2-RELEASE (i386) and the GENERIC kernel.

The device gets somewhat recognized, since "urtw" is loaded albeit with
an error:

urtw0: <vendor 0x0bda product 0x8187, class 0/0, rev 2.00/2.00, addr2> on sbus3
urtw0: could not allocate USB transfers, err=USB_ERR_NO_PIPE
device_attach: urtw0 attach returned 6

I also tried to load it through the Windows XP drivers via ndis (rtl8187B.sys
and the respective .inf), but while the module is compiled without warnings,
kldloading it still produces the same error. I have tried kldunloading
the if_urtw.ko module and re-kldloading the compiled one (in case there is something like a race condition) to no avail.

As a side-note, the device is correctly recognised, a driver is loaded and
it successfully connects to wireless networks under OpenBSD and Linux.