Bug 207278 - graphics/luxrender: don't build unused demos, fix build with updated openimageio
Summary: graphics/luxrender: don't build unused demos, fix build with updated openimageio
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Dmitry Marakasov
URL:
Keywords:
Depends on:
Blocks: 207061
  Show dependency treegraph
 
Reported: 2016-02-17 14:24 UTC by Dmitry Marakasov
Modified: 2016-03-07 11:10 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (danfe)


Attachments
Patch (934 bytes, patch)
2016-02-17 14:24 UTC, Dmitry Marakasov
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Marakasov freebsd_committer 2016-02-17 14:24:33 UTC
Created attachment 167111 [details]
Patch

- Don't build demos which are not used or installed; this also fixes build with new openimageio:

cd /wrkdirs/usr/ports/graphics/luxrender/work/luxrender-luxrays-8577ff287efb/samples/benchsimple && /usr/local/bin/cmake -E cmake_link_script CMakeFiles/benchsimple.dir/link.txt --verbose=1
/usr/local/libexec/ccache/c++   -O2 -pipe -fstack-protector -fno-strict-aliasing -Wall -Wno-long-long -msse -fPIC -DNDEBUG   -lpython2.7 -fstack-protector CMakeFiles/benchsimple.dir/benchsimple.cpp.o  -o ../../bin/benchsimple  -L/usr/local/lib  ../../lib/libluxrays.a /usr/local/lib/libpython2.7.so -pthread ../../lib/libluxrays.a /usr/local/lib/libembree.so /usr/local/lib/libboost_thread.so /usr/local/lib/libboost_program_options.so /usr/local/lib/libboost_filesystem.so /usr/local/lib/libboost_serialization.so /usr/local/lib/libboost_iostreams.so /usr/local/lib/libboost_regex.so /usr/local/lib/libboost_system.so /usr/local/lib/libboost_python.so /usr/local/lib/libOpenImageIO.so -Wl,-rpath,/usr/local/lib
/usr/local/lib/libboost_python.so: undefined reference to `PyUnicode_InternFromString'
/usr/local/lib/libboost_python.so: undefined reference to `PyUnicode_FromFormat'
/usr/local/lib/libboost_python.so: undefined reference to `PyUnicode_FromString'
/usr/local/lib/libboost_python.so: undefined reference to `PyBytes_Size'
/usr/local/lib/libboost_python.so: undefined reference to `PyUnicode_AsUTF8'
/usr/local/lib/libboost_python.so: undefined reference to `PyUnicode_FromEncodedObject'
/usr/local/lib/libboost_python.so: undefined reference to `PyBytes_AsString'
/usr/local/lib/libboost_python.so: undefined reference to `PyModule_Create2'
/usr/local/lib/libboost_python.so: undefined reference to `PyUnicode_AsWideChar'
/usr/local/lib/libboost_python.so: undefined reference to `PyUnicode_AsUTF8String'
/usr/local/lib/libboost_python.so: undefined reference to `PyUnicode_FromStringAndSize'
Comment 1 commit-hook freebsd_committer 2016-03-04 17:04:18 UTC
A commit references this bug:

Author: amdmi3
Date: Fri Mar  4 17:04:06 UTC 2016
New revision: 410138
URL: https://svnweb.freebsd.org/changeset/ports/410138

Log:
  - Don't build unused samples, fixes build with updated openimageio

  PR:		207278
  Submitted by:	amdmi3
  Approved by:	maintainer timeout (danfe, 2 weeks)

Changes:
  head/graphics/luxrender/files/patch-luxrays-CMakeLists.txt
Comment 2 Alexey Dokuchaev freebsd_committer 2016-03-07 11:10:41 UTC
Hmm, I do not seem to be able to reproduces the breakage after fresh "svn up /usr/ports/graphics".  Does it happen on specific FreeBSD version/arch/compiler combination?

I also do not see the reason to disable the builds when just adding missing ${PYTHON_LIBRARIES} should've fixed it.  Lots of demos are missing them, in fact, and I'd typically patch them (not sure why upstream won't just fix it in a long time).