Bug 207623 - graphics/mapserver: error with python mapscript
Summary: graphics/mapserver: error with python mapscript
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Wen Heping
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-01 19:56 UTC by jjachuf
Modified: 2016-03-11 00:16 UTC (History)
1 user (show)

See Also:
rakuco: maintainer-feedback? (wen)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jjachuf 2016-03-01 19:56:56 UTC
when compiled with support python-mapscript bad link library.


import mapscript
---------------------------------------------------------------------------
ImportError                               Traceback (most recent call last)
<ipython-input-1-17c56d8326d5> in <module>()
----> 1 import mapscript

/usr/local/lib/python2.7/site-packages/mapscript.py in <module>()
     26                 fp.close()
     27             return _mod
---> 28     _mapscript = swig_import_helper()
     29     del swig_import_helper
     30 else:

/usr/local/lib/python2.7/site-packages/mapscript.py in swig_import_helper()
     22         if fp is not None:
     23             try:
---> 24                 _mod = imp.load_module('_mapscript', fp, pathname, description)
     25             finally:
     26                 fp.close()

ImportError: Shared object "libmapserver.so.2" not found, required by "_mapscript.so"

libmapserver.so.2 is a symbolic link pointing to a nonexistent file [libmapserver.so.7.0.0]


I solved manually doing this:

# cd /usr/local/lib/
# rm libmapserver.so.2
# ln -s libmapserver.so.7.0.1 libmapserver.so.2
Comment 1 Raphael Kubo da Costa freebsd_committer 2016-03-02 23:08:41 UTC
Over to maintainer.
Comment 2 commit-hook freebsd_committer 2016-03-03 01:18:40 UTC
A commit references this bug:

Author: wen
Date: Thu Mar  3 01:17:52 UTC 2016
New revision: 409994
URL: https://svnweb.freebsd.org/changeset/ports/409994

Log:
  - Correct link the .so lib file

  PR:		207623
  Submitted by:	jjachuf@gmail.com

Changes:
  head/graphics/mapserver/Makefile
Comment 3 Wen Heping freebsd_committer 2016-03-03 01:20:33 UTC
The error does not only affect python mapscript, it exists for all options,
I fixed it just now, would you update your ports and try again ?

Thanks !

wen