Bug 207636 - [NEW PORT] devel/py-fluent-logger: Structured logger for Fluentd (Python)
Summary: [NEW PORT] devel/py-fluent-logger: Structured logger for Fluentd (Python)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Po-Chuan Hsieh
URL:
Keywords: feature, needs-qa, patch
: 207635 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-03-02 08:52 UTC by edwardchuang
Modified: 2018-03-12 21:19 UTC (History)
2 users (show)

See Also:


Attachments
shar file (3.08 KB, text/plain)
2016-03-02 08:52 UTC, edwardchuang
rakuco: maintainer-approval+
Details
revised shar file (3.08 KB, text/plain)
2016-03-04 07:01 UTC, edwardchuang
rakuco: maintainer-approval+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description edwardchuang 2016-03-02 08:52:17 UTC
Created attachment 167627 [details]
shar file

A structured logger for Fluentd in python
WWW: https://github.com/fluent/fluent-logger-python
Comment 1 edwardchuang 2016-03-02 08:52:39 UTC
*** Bug 207635 has been marked as a duplicate of this bug. ***
Comment 2 Raphael Kubo da Costa freebsd_committer 2016-03-03 16:53:56 UTC
Thanks for the patch. Can you please run `portlint -AC' on the port and fix the issues that it raises?
Comment 3 edwardchuang 2016-03-04 07:01:41 UTC
Created attachment 167704 [details]
revised shar file

fix with portlint -AC
Comment 4 Raphael Kubo da Costa freebsd_committer 2016-03-04 10:49:09 UTC
You've added a pkg-plist while using USE_PYTHON=autoplist. You need either one or the other.
Comment 5 edwardchuang 2016-03-04 12:55:15 UTC
It's my mistake, I'll use autoplist
Comment 6 edwardchuang 2016-03-04 12:55:37 UTC
(In reply to Raphael Kubo da Costa from comment #4)
It's my mistake, I'll use autoplist
Comment 7 Walter Schwarzenfeld freebsd_triage 2018-02-16 05:45:44 UTC
Any news here?
Comment 8 Walter Schwarzenfeld freebsd_triage 2018-03-09 11:51:12 UTC
In the meantime fluent-logger has 0.9.2
https://pypi.python.org/pypi/fluent-logger/

(on github 0.9.0)
https://github.com/fluent/fluent-logger-python
Comment 9 commit-hook freebsd_committer 2018-03-12 21:18:22 UTC
A commit references this bug:

Author: sunpoet
Date: Mon Mar 12 21:17:35 UTC 2018
New revision: 464322
URL: https://svnweb.freebsd.org/changeset/ports/464322

Log:
  Add py-fluent-logger 0.9.2

  Many web/mobile applications generate huge amount of event logs (cf. login,
  logout, purchase, follow, etc). To analyze these event logs could be really
  valuable for improving the service. However, the challenge is collecting these
  logs easily and reliably.

  Fluentd solves that problem by having: easy installation, small footprint,
  plugins, reliable buffering, log forwarding, etc.

  fluent-logger-python is a Python library, to record the events from Python
  application.

  WWW: https://github.com/fluent/fluent-logger-python

  PR:		207636
  Submitted by:	Edward Chuang <edwardchuang@gmail.com>

Changes:
  head/devel/Makefile
  head/devel/py-fluent-logger/
  head/devel/py-fluent-logger/Makefile
  head/devel/py-fluent-logger/distinfo
  head/devel/py-fluent-logger/pkg-descr
Comment 10 Po-Chuan Hsieh freebsd_committer 2018-03-12 21:19:28 UTC
Committed. Thanks!