Bug 207676 - ACPI Exception on Skylake Systems: PCI0.XHC_.RHUB.HS11
Summary: ACPI Exception on Skylake Systems: PCI0.XHC_.RHUB.HS11
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: CURRENT
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-acpi mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-03 12:03 UTC by Will Green
Modified: 2017-07-17 18:13 UTC (History)
7 users (show)

See Also:


Attachments
dmesg.boot from X11SSH-LN4F. (10.21 KB, text/plain)
2016-03-03 12:03 UTC, Will Green
no flags Details
11.0-CURRENT dmesg.boot from X11SSH-LN4F. (10.64 KB, text/plain)
2016-03-29 15:59 UTC, Will Green
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Will Green 2016-03-03 12:03:37 UTC
Created attachment 167681 [details]
dmesg.boot from X11SSH-LN4F.

I'm testing a new Skylake server based on the Supermicro X11SSH-LN4F motherboard.

When booting I see the following ACPI Error/Exception:

FreeBSD 10.3-BETA3 #0 r296074: Fri Feb 26 01:13:37 UTC 2016
    root@releng1.nyi.freebsd.org:/usr/obj/usr/src/sys/GENERIC amd64
FreeBSD clang version 3.4.1 (tags/RELEASE_34/dot1-final 208032) 20140512
CPU: Intel(R) Xeon(R) CPU E3-1260L v5 @ 2.90GHz (2904.14-MHz K8-class CPU)
  Origin="GenuineIntel"  Id=0x506e3  Family=0x6  Model=0x5e  Stepping=3
...
ioapic0 <Version 2.0> irqs 0-23 on motherboard
kbd1 at kbdmux0
acpi0: <SUPERM SUPERM> on motherboard
ACPI Error: [\134_SB_.PCI0.XHC_.RHUB.HS11] Namespace lookup failure, AE_NOT_FOUND (20150515/dswload-219)
ACPI Exception: AE_NOT_FOUND, During name lookup/catalog (20150515/psobject-233)
acpi0: Power Button (fixed)
unknown: memory range not supported
cpu0: <ACPI CPU> on acpi0
...

I have attached the full boot dmesg for reference.

PS. I have assigned this to 10.3-BETA2 because 10.3-BETA3 was not in the Version list.
Comment 1 Will Green 2016-03-29 15:54:35 UTC
I've confirmed that a varient of this issue also occurs in 11-Current (built from FreeBSD-11.0-CURRENT-amd64-20160308-r296485-memstick.img):

acpi0: <SUPERM SUPERM> on motherboard
ACPI Error: [\134_SB_.PCI0.XHC_.RHUB.HS11] Namespace lookup failure, AE_NOT_FOUND (20150818/dswload-219)
ACPI Exception: AE_NOT_FOUND, During name lookup/catalog (20150818/psobject-237)
ACPI Exception: AE_NOT_FOUND, (SSDT:xh_Zumba) while loading table (20150818/tbxfload-211)
ACPI Error: 1 table load failures, 7 successful (20150818/tbxfload-235)
acpi0: Power Button (fixed)
unknown: memory range not supported
cpu0: <ACPI CPU> on acpi0

I will attached the dmesg.boot from 11.0-Current to the bug.
Comment 2 Will Green 2016-03-29 15:59:56 UTC
Created attachment 168760 [details]
11.0-CURRENT dmesg.boot from X11SSH-LN4F.
Comment 3 Mark Dixon 2016-03-29 21:53:09 UTC
I see this too, on a Skylake desktop:

acpi0: <ALASKA A M I > on motherboard
ACPI Error: [\134_SB_.PCI0.XHC_.RHUB.HS11] Namespace lookup failure, AE_NOT_FOUND (20150515/dswload-219)
ACPI Exception: AE_NOT_FOUND, During name lookup/catalog (20150515/psobject-233)
acpi0: Power Button (fixed)
Comment 4 Silvan Burch 2016-05-19 16:54:54 UTC
same here:

ACPI Error: [\134_SB_.PCI0.XHC_.RHUB.HS11] Namespace lookup failure, AE_NOT_FOUN
D (20150515/dswload-219)                                                        
ACPI Error: [\134_SB_.PCI0.XHC_.RHUB.HS11] Namespace lookup failure, AE_NOT_FOUN
D (20150515/dswload-219)   


on a ASRock Rack C236 WSI
Intel i3-6100
FreeNAS 9.10
Comment 5 Silvan Burch 2016-05-23 16:01:31 UTC
Since it seems the post kinda died, I wrote Will Green directly and he told me there was no solution yet.

Anyone else found something?
Comment 6 Silvan Burch 2016-05-31 13:03:30 UTC
well I'll try to push one more time ... hope anyone has an idea?

Thanks and best regards
Comment 7 John Baldwin freebsd_committer freebsd_triage 2016-06-24 21:20:55 UTC
Your BIOS is referencing a function or variable that it isn't defining.  There's not much FreeBSD can do about that (we have no idea what the missing variable or function is supposed to be or do).  Do you see anything broken or just the warning?
Comment 8 Will Green 2016-06-27 09:49:34 UTC
Given the name I'm guessing the error is related to USB/XHCI. This is a server system and I make minimal use of USB, so I haven't seen any issues I can attribute to this.

However, from what I've seen & heard this issue occurs on a wide range of Skylake (and similar generation) systems: it's not confined to a specific BIOS or motherboard manufacturer.

Looking at the Linux kernel list it seems they've also encountered this issue and have a fix https://bugzilla.kernel.org/show_bug.cgi?id=117671

I hope this information is of some help.
Comment 9 Yakko 2017-05-15 22:03:51 UTC
May I be so kind to mention that, a year later, this issue is still relevant Which means that i am unable to run FreeNAS or any other FreeBSD based solution on modern hardware.

I have the following issue on my server.

System:
  Mobo: Fujitsu D3417-B1
  CPU: Pentium i3-6300 with 64GB ECC RAM
  OS: FreeNAS 9.10.2-U3 or FreeNAS 11 MASTER-201705150408 (doesn't matter)

Two ACPI Errors, (Dump):

ACPI Error: [\_SB_.PCI0.LPCB.H_EC.ECAV] Namespace lookup failure,
AE_NOT_FOUND (20160527/psargs-391)

ACPI Error: Method parse/execution failed [\_TZ_.TZ00._TMP] (Node
0xfffff8000d4faf00), AE_NOT_FOUND (20160527/psparse-559) 


How can I help to fix this issue? I would like to run FreeNAS, but I have no clue on how to move forward. Can anyone state something regarding the nature of the error?

Debian (ProxMox) runs without issues on the same hardware so I am not entirely sure what this issue causes?
Comment 10 John Baldwin freebsd_committer freebsd_triage 2017-05-16 15:37:59 UTC
As the link to the Linux bug report noted, this was an issue fixed upstream in ACPICA, so presumably it will be fixed by an import of newer ACPICA versions to FreeBSD.  FreeBSD 11-stable and 12-current already contain newer ACPICA versions than that which was used when this bug report was opened.  Would someone be able to test a recent snapshot of head or 11-stable?

Also, it's still not clear if there are any runtime effects apart from the warning message during boot.
Comment 11 Mason Loring Bliss 2017-05-24 22:11:03 UTC
I hadn't noticed the error messages until someone pointed me at this ticket, but a runtime effect on my Intel(R) Xeon(R) CPU E3-1225 v5 @ 3.30GHz was "sysctl -a" consuming 100% of a core and being unkillable without a reboot. Boy, was I surprised when I found that!

I've since removed FreeBSD from the machine in question as it's my primary desktop and I needed something that didn't have these gotchas, but I'll see about testing a snapshot before long.
Comment 12 Mason Loring Bliss 2017-05-25 00:10:46 UTC
Addendum: I just had An Adventure where the FreeBSD installer somehow managed to re-order my drives or... something... nuking GRUB2 in the process. But in any event, I've managed to recover with rescue media, so I'm able to report on the test I ran.

As of FreeBSD-11.1-PRERELEASE-amd64-20170519-r318507 I'm able to run 'sysctl -a' and it will show me what looks like a complete set of data. It doesn't hang, doesn't consume all of a CPU core, and appears to exit normally.
Comment 13 John Baldwin freebsd_committer freebsd_triage 2017-07-17 16:32:42 UTC
(In reply to Mason Loring Bliss from comment #12)
Were the warnings no longer present in your 11.1-PRERELEASE test as well?  If so, it seems that the newer ACPICA in 11.1 includes the fix for this issue and it can be closed.  (ACPICA upgrades are too large of a change to backport as an EN to release branches like 11.0).
Comment 14 Mason Loring Bliss 2017-07-17 17:13:21 UTC
Correct. The issue appears to have been resolved, and this bug can be closed. (Agreed, there's little reason to backport to 11.0 as long as folks understand that they need to run 11.1 if they experience this.)