Bug 207726 - Headphone doesn't work after logging in Debian and then log back into FreeBSD
Summary: Headphone doesn't work after logging in Debian and then log back into FreeBSD
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: 10.2-RELEASE
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-multimedia mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-05 19:51 UTC by nwhere3
Modified: 2016-08-08 08:11 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nwhere3 2016-03-05 19:51:04 UTC

    
Comment 1 nwhere3 2016-03-05 19:56:00 UTC
Hi everyone
I'm new to FreeBSD
Comment 2 nwhere3 2016-03-05 20:29:29 UTC
hi,
i'm new to FreeBSD and think i'm the first one having this problem:
i have dual-booted Debian and FreeBSD using Grub2. Headphones worked well at the beginning, but after i logged in Debian and then logged back into FreeBSD, headphone stopped working while my laptop's internal speaker worked well (without headphone). After rebooting several times and then logging back into FreeBSD, headphone started working again, and then it stopped working agian after rebooting the system. i didn't modify anything related to the snd_hda.  i have also looked at the dmesg after pindumping. it seems nothing wrong with hdac.   
can somebody help me?
Comment 3 Jason Unovitch freebsd_committer 2016-04-05 01:26:51 UTC
(In reply to nwhere3 from comment #2)
I have no familiarity with the underlying code here but just throwing in my two cents that I have seen this dual booting between Ubuntu and Windows on a system where after booting in Windows the sound would no longer work in Ubuntu. A soft reboot back into Windows would have good sound. Only a hard, pull the power plug and plug it back in, seemed to reset whatever hardware state the system was in so that sound would work in Ubuntu. I replicated this multiple times. Never figured out what was wrong on the system but I haven't dual booted into Windows in over a year and FreeBSD runs fine. Maybe the hard reset may also be a viable workaround in your case.