Bug 207743 - contrib/telnet uses deprecated des_* methods
Summary: contrib/telnet uses deprecated des_* methods
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: CURRENT
Hardware: Any Any
: --- Affects Only Me
Assignee: Bernard Spil
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2016-03-06 13:49 UTC by Bernard Spil
Modified: 2016-04-06 07:52 UTC (History)
2 users (show)

See Also:


Attachments
git diff for contrib/telnet (5.62 KB, patch)
2016-03-06 13:49 UTC, Bernard Spil
delphij: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Bernard Spil freebsd_committer 2016-03-06 13:49:28 UTC
Created attachment 167762 [details]
git diff for contrib/telnet

OpenSSL has deprecated a large number of des_ methods and types on 24 October 2001[1]. The upcoming OpenSSL version 1.1[2] has also removed these methods and so has LibreSSL.

Attached patch replaces the des_ methods with their DES_ equivalents.

[1] https://github.com/openssl/openssl/commit/c2e4f17c1a0d4d5115c6ede9492de1615fe392ac
[2] https://github.com/openssl/openssl/commit/24956ca00f014a917fb181a8abc39b349f3f316f
Comment 1 Bernard Spil freebsd_committer 2016-03-07 15:58:54 UTC
Patch is required on 10.3 as well and applies cleanly
Comment 2 Xin LI freebsd_committer 2016-04-06 07:52:26 UTC
Comment on attachment 167762 [details]
git diff for contrib/telnet

Looks good to me. (consider this as a src/ approval)
Comment 3 Xin LI freebsd_committer 2016-04-06 07:52:57 UTC
Over to submitter (who have a commit bit).