Bug 207937 - make japanese/mozc-server buildable with DEFAULT_VERSIONS=python=3.5
Summary: make japanese/mozc-server buildable with DEFAULT_VERSIONS=python=3.5
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Ruslan Makhmatkhanov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-12 23:03 UTC by Hiroo Ono
Modified: 2016-10-13 11:40 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (hrs)


Attachments
patch to Makefile that force use of python2. (1.31 KB, patch)
2016-03-12 23:03 UTC, Hiroo Ono
no flags Details | Diff
Fix packaging with python 3 and fix filesystem violation (1.55 KB, patch)
2016-09-24 12:29 UTC, Ruslan Makhmatkhanov
rm: maintainer-approval? (hrs)
Details | Diff
poudriere build log (60.00 KB, text/plain)
2016-09-24 12:31 UTC, Ruslan Makhmatkhanov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hiroo Ono 2016-03-12 23:03:44 UTC
Created attachment 168065 [details]
patch to Makefile that force use of python2.

The japanese/mozc-server port does not build with DEFAULT_VERSIONS=python=3.5.
The python scripts used in building it are for python2, so use python2 and make it to build with DEFAULT_VERSIONS=python=3.5.
Comment 1 Ruslan Makhmatkhanov freebsd_committer 2016-09-24 12:29:40 UTC
Created attachment 175120 [details]
Fix packaging with python 3 and fix filesystem violation

Here is the updated patch, that forces python2.x for build, but makes it to not depend upon python2 metaport. It is also removes duplicated python direct build  dependency and fixing packaging by fixing this error:

====>> Checking for filesystem violations... done
====>> Error: Filesystem touched during build:
extra: root/.mozc

Hiroki-san, would you approve?
Comment 2 Ruslan Makhmatkhanov freebsd_committer 2016-09-24 12:31:35 UTC
Created attachment 175122 [details]
poudriere build log
Comment 3 commit-hook freebsd_committer 2016-10-12 19:08:47 UTC
A commit references this bug:

Author: rm
Date: Wed Oct 12 19:07:59 UTC 2016
New revision: 423884
URL: https://svnweb.freebsd.org/changeset/ports/423884

Log:
  japanese/mozc-server: with build with python3

  - limit python version to python 2.7
  - remove duplicated python direct build dependency
  - set correct python version in build scripts
  - fix packaging by not installing to /root:

    ====>> Checking for filesystem violations... done
    ====>> Error: Filesystem touched during build:
    extra: root/.mozc

  PR:		207937
  Submitted by:	Hiroo Ono <hiroo.ono+freebsd@gmail.com> (based on)
  Approved by:	maintainer timeout (14 days)

Changes:
  head/japanese/mozc-server/Makefile
Comment 4 Ruslan Makhmatkhanov freebsd_committer 2016-10-12 19:09:19 UTC
Fix committed, thank you!
Comment 5 Sandra 2016-10-13 09:39:01 UTC
I know only the basis of python and didn't quite get why if you use python2 the build should be committed with the version python=3.5. Never encounter such issues at http://thetermpapers.net before.
Comment 6 Hiroo Ono 2016-10-13 11:07:55 UTC
The problem is that the build scripts they use is in python2 and do not run with python3. At a glance, it did not seem to be fixable easily (with some replacements or so), so I chose to specify python2 for building.
The problem should be addressed upstream, I think.
Comment 7 Ruslan Makhmatkhanov freebsd_committer 2016-10-13 11:40:48 UTC
(In reply to Hiroo Ono from comment #6)
It's a spam post if I understand correctly, but now I see the point of a first part of the message. Without this fix, when at some point python3.5 (and some users already do it locally) would be our default python version, mozc-server would be one of the ports, we'll face problems with.