Bug 207941 - databases/py-qt4-sql failed to determine the layout of Qt install during x11/kde4 build
Summary: databases/py-qt4-sql failed to determine the layout of Qt install during x11/...
Status: Closed Feedback Timeout
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: kde
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-13 06:51 UTC by mikhail.rokhin
Modified: 2016-09-28 20:51 UTC (History)
2 users (show)

See Also:
rakuco: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mikhail.rokhin 2016-03-13 06:51:53 UTC
Just failed.

Unable to get extra info from virtualbox machine (CURRENT is unable to run Gnome3 and kde4 fails to compile).
Comment 1 mikhail.rokhin 2016-03-13 08:10:40 UTC
...but!!)) 

Whether it's compiled withing pkg-installed qt4 packages it succeeds, otherwise (compiled by CURRENT clang 3.8.0 and latest ports) it fails.

Seems like there is smth hardcoded, not flexible within the port, smth about version or schema check...
Comment 2 Raphael Kubo da Costa freebsd_committer 2016-03-13 13:32:21 UTC
Just like with bug 207919, your feedback is appreciated, but offers too little information for us to be able to do anything with it.

I've just tried building the mentioned port on Poudriere and everything worked as expected.

Without an error log and more information about whether you have any customizations with your builds we cannot fix anything.