Bug 208033 - [exp-run] Update CMake to 3.5.0
Summary: [exp-run] Update CMake to 3.5.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Raphael Kubo da Costa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-15 16:51 UTC by Raphael Kubo da Costa
Modified: 2016-03-19 14:42 UTC (History)
2 users (show)

See Also:


Attachments
Patch v1 (10.17 KB, patch)
2016-03-15 16:51 UTC, Raphael Kubo da Costa
no flags Details | Diff
Patch v2 (26.33 KB, patch)
2016-03-17 16:35 UTC, Raphael Kubo da Costa
no flags Details | Diff
Patch v3 (27.24 KB, patch)
2016-03-18 13:29 UTC, Raphael Kubo da Costa
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Raphael Kubo da Costa freebsd_committer 2016-03-15 16:51:07 UTC
Created attachment 168244 [details]
Patch v1

kde@ would like to request an exp-run for updating devel/cmake{-gui,-modules} to 3.5.0.

The patch is attached and also available here: <https://people.freebsd.org/~rakuco/exp-runs/cmake-3.5.0-v1.patch>.
Comment 1 Raphael Kubo da Costa freebsd_committer 2016-03-16 17:57:58 UTC
I haven't been able to reproduce the kdevplatform, aqemu, telepathy-qt4 and oggvideotools failures reported on 10-i386 locally on my 11amd64 Poudriere jail.

I have a hunch that this is 10-specific and related to libc++. To be sure, can you trigger an 11 build after the 93amd64 one finishes?
Comment 2 Raphael Kubo da Costa freebsd_committer 2016-03-17 13:12:19 UTC
(In reply to Raphael Kubo da Costa from comment #1)
> I haven't been able to reproduce the kdevplatform, aqemu, telepathy-qt4 and
> oggvideotools failures reported on 10-i386 locally on my 11amd64 Poudriere
> jail.

OK, I know what's wrong with aqemu, telepathy-qt4 and kdevplatform. oggvideotools wasn't broken by the CMake update (Ports Fury's patch from bug 207990 is broken everywhere). I still need to fix gnuradio.

> I have a hunch that this is 10-specific and related to libc++. To be sure,
> can you trigger an 11 build after the 93amd64 one finishes?

This isn't needed anymore in case you haven't started it, but I'll send a patch v2 later to double-check everything works.
Comment 3 Raphael Kubo da Costa freebsd_committer 2016-03-17 16:35:05 UTC
Created attachment 168329 [details]
Patch v2

Patch v2 attached and also available here: <https://people.freebsd.org/~rakuco/exp-runs/cmake-3.5.0-v2.patch>.

I believe everything should build fine now.
Comment 4 Raphael Kubo da Costa freebsd_committer 2016-03-17 22:25:19 UTC
Sigh, telepathy-qt4 is still failing. I'll look into it tomorrow.
Comment 5 Raphael Kubo da Costa freebsd_committer 2016-03-18 13:29:16 UTC
Created attachment 168369 [details]
Patch v3

Patch v3 is up, here and in <https://people.freebsd.org/~rakuco/exp-runs/cmake-3.5.0-v3.patch>.

telepathy-qt4 should build now.
Comment 7 commit-hook freebsd_committer 2016-03-19 14:19:08 UTC
A commit references this bug:

Author: rakuco
Date: Sat Mar 19 14:18:40 UTC 2016
New revision: 411399
URL: https://svnweb.freebsd.org/changeset/ports/411399

Log:
  Add a patch to explicitly link against libfplib.so.

  What the port was doing was never right, but the upcoming CMake 3.5.0 makes the
  build failures happen more often.

  Using target_link_libraries() with a name like fplib will just pass -lfplib to
  the linker instead of declaring a dependency between the lastfm-fpclient and
  fplib_shared targets and parallel builds may break.

  PR:		208033

Changes:
  head/audio/fplib/files/
  head/audio/fplib/files/patch-CMakeLists.txt
Comment 8 commit-hook freebsd_committer 2016-03-19 14:22:10 UTC
A commit references this bug:

Author: rakuco
Date: Sat Mar 19 14:21:39 UTC 2016
New revision: 411400
URL: https://svnweb.freebsd.org/changeset/ports/411400

Log:
  Add a patch to fix the build with CMake 3.5.0.

  Starting with CMake 3.5.0, overriding CMAKE_{BINARY,SOURCE}_DIR does not
  propagate to other files included with add_subdirectories(); in fact, doing so
  should in general be avoided.

  Add a patch to use PROJECT_{BINARY,SOURCE}_DIR instead, which works with all
  CMake versions.

  This is also being discussed upstream in
  <https://github.com/gnuradio/volk/pull/65>.

  PR:		208033
  Obtained from:	Fedora Project

Changes:
  head/comms/gnuradio/files/patch-cmake-3.5.0
Comment 9 commit-hook freebsd_committer 2016-03-19 14:24:14 UTC
A commit references this bug:

Author: rakuco
Date: Sat Mar 19 14:23:54 UTC 2016
New revision: 411402
URL: https://svnweb.freebsd.org/changeset/ports/411402

Log:
  Add a patch to properly declare some build dependencies.

  The lack of the dependency breaks parallel builds way more often starting with
  CMake 3.5.0.

  PR:		208033

Changes:
  head/devel/kdevplatform/files/patch-plugins_filetemplates_CMakeLists.txt
Comment 10 commit-hook freebsd_committer 2016-03-19 14:26:15 UTC
A commit references this bug:

Author: rakuco
Date: Sat Mar 19 14:26:05 UTC 2016
New revision: 411403
URL: https://svnweb.freebsd.org/changeset/ports/411403

Log:
  Add patch to stop building the libvncclient target.

  The libvncclient target was removed because it was not used anywhere (aqemu
  links against the systems libvncclient.so, only the definitions and includes
  are needed from this block) and did not declare its dependency on the moc and
  ui files, possibly causing problems in parallel builds (way more often with
  CMake 3.5.0).

  PR:		208033

Changes:
  head/emulators/aqemu/files/patch-CMakeLists.txt
Comment 11 commit-hook freebsd_committer 2016-03-19 14:37:17 UTC
A commit references this bug:

Author: rakuco
Date: Sat Mar 19 14:36:55 UTC 2016
New revision: 411404
URL: https://svnweb.freebsd.org/changeset/ports/411404

Log:
  Add some patches to properly declare dependencies between targets.

  The upcoming CMake 3.5.0 ends up generating Makefiles that cause much more
  problems in parallel builds when the dependencies are not declared correctly.

  This also allows us to get rid of MAKE_JOBS_UNSAFE.

  PR:		208033

Changes:
  head/games/vavoom/Makefile
  head/games/vavoom/files/patch-progs_common_CMakeLists.txt
  head/games/vavoom/files/patch-source_CMakeLists.txt
Comment 12 commit-hook freebsd_committer 2016-03-19 14:39:19 UTC
A commit references this bug:

Author: rakuco
Date: Sat Mar 19 14:38:36 UTC 2016
New revision: 411407
URL: https://svnweb.freebsd.org/changeset/ports/411407

Log:
  Add some upstream patches that properly declare all build dependencies.

  The upcoming CMake 3.5.0 generates Makefiles that break parallel builds more
  often when the dependencies between each targets are not declared correctly.

  PR:		208033

Changes:
  head/net-im/telepathy-qt4/files/patch-git_1e1f53e9
  head/net-im/telepathy-qt4/files/patch-git_7389dc9
Comment 13 commit-hook freebsd_committer 2016-03-19 14:42:22 UTC
A commit references this bug:

Author: rakuco
Date: Sat Mar 19 14:41:39 UTC 2016
New revision: 411409
URL: https://svnweb.freebsd.org/changeset/ports/411409

Log:
  Update CMake to 3.5.0.

  Announcement: https://blog.kitware.com/cmake-3-5-0-available-for-download/

  Most ports have already been fixed for this update, but science/orthanc was
  included in this commit because I am not entirely sure the changes in it work
  with CMake < 3.5.0. In short, FindDCMTK.cmake was rewritten and the way orthanc
  uses the DCMTK variables was incompatible with the use upstream intended.

  PR:		208033

Changes:
  head/devel/cmake/Makefile
  head/devel/cmake/distinfo
  head/devel/cmake/files/patch-Modules_FindDCMTK.cmake
  head/devel/cmake/files/patch-git_9d653f9c
  head/devel/cmake/pkg-plist
  head/devel/cmake-gui/Makefile
  head/devel/cmake-modules/pkg-plist
  head/science/orthanc/Makefile
  head/science/orthanc/files/patch-Resources_CMake_DcmtkConfiguration.cmake