Bug 208078 - Reset password for kami and merge accounts
Summary: Reset password for kami and merge accounts
Status: Closed Works As Intended
Alias: None
Product: Services
Classification: Unclassified
Component: Bug Tracker (show other bugs)
Version: unspecified
Hardware: Any Any
: --- Affects Only Me
Assignee: Kubilay Kocak
URL:
Keywords: dogfood, easy
Depends on:
Blocks:
 
Reported: 2016-03-17 09:29 UTC by kamikaze
Modified: 2017-02-22 08:09 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kamikaze 2016-03-17 09:29:27 UTC
The passphrase for my account kami@freebsd.org is rejected and I cannot change it. I also wanted to request an account merge.
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2016-03-17 10:49:42 UTC
Bugzilla uses cluster authentication (LDAP). The process for
changing/resetting passwords is:

1) ssh to freefall.  run 'kinit'.  If you know what your kerberos
password is and it works, then you are good to go.

2) if you don't know what it is, instead ssh to 'kpasswd.freebsd.org'
using your regular ssh credentials.  This will generate a new random
kerberos password for you.  After this, you should be able to do the
'kinit' from step 1.

3) If you want to change your password because you don't like the evil
random password from step 2, ssh to freefall and change the password
with the 'kpasswd' command.  Follow the prompts.  You should be good for
kinit after this.

Please confirm after successfully resetting your password
Comment 2 Dominic Fandrey freebsd_committer 2016-03-17 12:21:29 UTC
How embarrassing, I skipped straight to the bugzilla chapter in the comitter's guide, not looking at kerberos.
Comment 3 Dominic Fandrey freebsd_committer 2017-02-22 08:09:04 UTC
Has long been resolved.