Bug 208102 - misc/mc: 4.8.16 has subshell disabled for SHELL=/bin/csh
Summary: misc/mc: 4.8.16 has subshell disabled for SHELL=/bin/csh
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Mark Felder
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-17 22:36 UTC by Zmiter
Modified: 2016-03-18 12:05 UTC (History)
3 users (show)

See Also:
woodsb02: maintainer-feedback+


Attachments
Fix subshell disabled problem for SHELL=/bin/csh (522 bytes, text/plain)
2016-03-17 22:36 UTC, Zmiter
no flags Details
Patch from upstream ticket 2742 to fix subshell problem (1.61 KB, patch)
2016-03-17 23:18 UTC, Ben Woods
woodsb02: maintainer-approval+
Details | Diff
QA: Successful poudriere testport logs for misc/mc 4.8.16 with patch on FreeBSD 10.2 amd64 (178.79 KB, text/plain)
2016-03-17 23:19 UTC, Ben Woods
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zmiter 2016-03-17 22:36:01 UTC
Created attachment 168338 [details]
Fix subshell disabled problem for SHELL=/bin/csh

While implementing "Support for ash + bugfixes for bash, fish (#2742)" the /bin/csh was forgotten and no subshell working in mc. When you press Ctrl-o pannels are disappearing, but csh command prompt is not there.

The problem is in treating the /bin/csh as symlink to /bin/tcsh, which actually is the hardlink.

The link to the ticket: https://www.midnight-commander.org/ticket/2742

The patch is attached.
Comment 1 Ben Woods freebsd_committer 2016-03-17 23:18:47 UTC
Created attachment 168343 [details]
Patch from upstream ticket 2742 to fix subshell problem

I have updated the patch provided by Zmiter from upstream to be relative to the FreeBSD ports base directory, and to bump the PORTREVISION. Thanks for the bug report Zmiter.
Comment 2 Ben Woods freebsd_committer 2016-03-17 23:19:56 UTC
Created attachment 168344 [details]
QA: Successful poudriere testport logs for misc/mc 4.8.16 with patch on FreeBSD 10.2 amd64
Comment 3 commit-hook freebsd_committer 2016-03-18 12:05:01 UTC
A commit references this bug:

Author: feld
Date: Fri Mar 18 12:04:33 UTC 2016
New revision: 411345
URL: https://svnweb.freebsd.org/changeset/ports/411345

Log:
  misc/mc: Multiple fixes

  - Fix subshell functionality for csh users
  - Make SFTP an option, enabled by default
  - Fix SIGILL on FreeBSD 9.x
  - Fix perl ls helper with fish shell

  PR:		207487, 208027, 208102, 208104

Changes:
  head/misc/mc/Makefile
  head/misc/mc/files/patch-upstreamticket2742-detect-csh-as-tcsh-by-name.patch
  head/misc/mc/files/patch-upstreamticket3611-fish-fix-perl-ls-helper.patch
  head/misc/mc/files/patch-upstreamticket3617-mc_open-handle-varargs-mode_t-promotion-issue--v2.patch
Comment 4 Mark Felder freebsd_committer 2016-03-18 12:05:48 UTC
Committed, thanks!