Bug 208112 - x11/tint: Update to 0.12.7
Summary: x11/tint: Update to 0.12.7
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kurt Jaeger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-18 07:35 UTC by yamagi
Modified: 2016-03-18 20:42 UTC (History)
1 user (show)

See Also:


Attachments
Update to x11/tint (744 bytes, patch)
2016-03-18 07:35 UTC, yamagi
yamagi: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description yamagi 2016-03-18 07:35:40 UTC
Created attachment 168357 [details]
Update to x11/tint

Hello,
the attached svn patch updates x11/tint to version 0.12.7. This is another bugfix release with only a small set of changes. The applications changelog can be found here: https://gitlab.com/o9000/tint2/blob/0.12.7/ChangeLog

Changes to the port are:
* Just the version bump

This updated was tested with poudriere on FreeBSD 9.3, 10.1 and 10.2. And I've used the new version for 48 hours on my desktop.
Comment 1 Kurt Jaeger freebsd_committer 2016-03-18 20:30:12 UTC
testbuilds look fine.
Comment 2 commit-hook freebsd_committer 2016-03-18 20:34:44 UTC
A commit references this bug:

Author: pi
Date: Fri Mar 18 20:33:49 UTC 2016
New revision: 411369
URL: https://svnweb.freebsd.org/changeset/ports/411369

Log:
  x11/tint: 0.12.6 -> 0.12.7

  Changes:
    https://gitlab.com/o9000/tint2/blob/0.12.7/ChangeLog
  - Fix crash caused by race when reading inconsistent values for
    _NET_CURRENT_DESKTOP and _NET_NUMBER_OF_DESKTOPS
  - Fix regression (all desktop tasks not working)
  - Fix small memory leak in launcher

  PR:		208112
  Submitted by:	yamagi@yamagi.org (maintainer)

Changes:
  head/x11/tint/Makefile
  head/x11/tint/distinfo
Comment 3 Kurt Jaeger freebsd_committer 2016-03-18 20:42:29 UTC
Committed, thanks!