Bug 208241 - [Hyper-V] VM network may not work over virtual switch based on wireless NIC
Summary: [Hyper-V] VM network may not work over virtual switch based on wireless NIC
Status: Closed Works As Intended
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: CURRENT
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-virtualization mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-23 13:16 UTC by Dexuan Cui
Modified: 2016-07-11 09:39 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dexuan Cui 2016-03-23 13:16:42 UTC
I tried FreeBSD 11-CURRENT VM on Windows 10 host and found the VM network could easily stop working about 5 minutes after the VM finished bootup.

After some debugging, it seems the host virtual switch has some issue for wireless NIC. It seems if we change the default ARP expiration time from the default 1200 seconds to 60s, the issue will disappear.

Details about the workaround:

Add "net.link.ether.inet.max_age=60"  into /etc/sysctl.conf and reboot the VM.

Or, "sysctl net.link.ether.inet.max_age=60" and "arp -d -a".
Comment 1 Dexuan Cui 2016-07-11 09:39:41 UTC
The real cause of the issue should exist in the Hyper-V host side and it's unlikely to get this fixed in the near future considering the effort needed and its priority, as far as I can tell.

And since we have an effective workaround (see the original description when I reported the bug), let me close the bug -- I chose "Works As Intended" because I couldn't find a better type like "WON'T FIX". Feel free to correct this, if you know how to do it.