Bug 208272 - ports-mgmt/portlint: spurious warning without PORTSDIR
Summary: ports-mgmt/portlint: spurious warning without PORTSDIR
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Joe Marcus Clarke
URL:
Keywords:
: 208673 (view as bug list)
Depends on: 203685
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-24 23:25 UTC by Jan Beich
Modified: 2016-04-15 18:31 UTC (History)
5 users (show)

See Also:
amdmi3: maintainer-feedback+


Attachments
Patch that should fix it (457 bytes, patch)
2016-03-25 08:09 UTC, Baptiste Daroussin
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2016-03-24 23:25:32 UTC
Adding ${PORTSDIR} on _DEPENDS line is no longer necessary since 2016Q1 branched. I've added a few ports with it e.g.,

  $ cd devel/py-re2; portlint -C
  WARN: Makefile: no port directory lang/cython found, even though it is listed in BUILD_DEPENDS.
  WARN: Makefile: no port directory devel/re2 found, even though it is listed in LIB_DEPENDS.
  0 fatal errors and 2 warnings found.
Comment 1 Baptiste Daroussin freebsd_committer 2016-03-25 08:09:29 UTC
Created attachment 168603 [details]
Patch that should fix it

Here is a patch that should fix it
Comment 2 Enji Cooper freebsd_committer 2016-04-06 05:24:50 UTC
(In reply to Baptiste Daroussin from comment #1)

Yeah, that seems correct..
Comment 3 Enji Cooper freebsd_committer 2016-04-06 05:25:40 UTC
(In reply to Ngie Cooper from comment #2)

Well, with exception of the fact that I would probably avoid a greedy glob, i.e. use `+` instead of `*`.
Comment 4 Dmitry Marakasov freebsd_committer 2016-04-06 14:55:47 UTC
See also my simpler patch https://reviews.freebsd.org/D5843 which drops support for ${PORTSDIR} completely.
Comment 5 Baptiste Daroussin freebsd_committer 2016-04-06 15:44:03 UTC
I agree Dmitry has a better version :)
Comment 6 Dmitry Marakasov freebsd_committer 2016-04-11 17:10:28 UTC
*** Bug 208673 has been marked as a duplicate of this bug. ***
Comment 7 Dmitry Marakasov freebsd_committer 2016-04-11 17:12:31 UTC
Maintainer timeout.
Comment 8 Dmitry Marakasov freebsd_committer 2016-04-11 20:28:02 UTC
Jan, Ngie, any objections for committing my version?
Comment 9 Joe Marcus Clarke freebsd_committer 2016-04-11 20:36:16 UTC
I have committed Dmitry's patch to my CVS repo pending the next release (very soon).
Comment 10 Dmitry Marakasov freebsd_committer 2016-04-11 20:51:12 UTC
Great, thank you!
Comment 11 Joe Marcus Clarke freebsd_committer 2016-04-13 16:28:29 UTC
Moving to In Progress.
Comment 12 commit-hook freebsd_committer 2016-04-15 18:30:56 UTC
A commit references this bug:

Author: marcus
Date: Fri Apr 15 18:30:42 UTC 2016
New revision: 413367
URL: https://svnweb.freebsd.org/changeset/ports/413367

Log:
  Update to 2.17.0.

  * Drop the need for PORTSDIR in dependencies [1]
  * Allow a trailing ':' in URLs [2]
  * Check to make sure the value(s) of SUB_FILES is healthy [3]
  * Expand variables on all sides of the dependency tuple [4]
    (this last change is rather big, and thus bumping minor version)

  PR:		208272 [1]
  		207843 [2]
  		207477 [3]
  		206061 [4]
  Submitted by:	amdmi3 [1]

Changes:
  head/ports-mgmt/portlint/Makefile
  head/ports-mgmt/portlint/src/portlint.pl
Comment 13 Joe Marcus Clarke freebsd_committer 2016-04-15 18:31:09 UTC
Committed, thanks!