Bug 208277 - [PATCH] print/latex-biber missing runtime dependency
Summary: [PATCH] print/latex-biber missing runtime dependency
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Tobias Kortkamp
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2016-03-25 05:35 UTC by Tobias Brodel
Modified: 2018-03-14 11:39 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (hrs)


Attachments
Patch to print/latex-biber/Makefile (533 bytes, patch)
2016-03-25 05:35 UTC, Tobias Brodel
no flags Details | Diff
poudriere log for print/latex-biber (58.13 KB, text/plain)
2016-03-25 05:36 UTC, Tobias Brodel
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Brodel 2016-03-25 05:35:47 UTC
Created attachment 168594 [details]
Patch to print/latex-biber/Makefile

biber fails out of the box due to a missing dependency on net/p5-URI

Steps to reproduce:

Perform fresh install of print/latex-biber (in jail or otherwise clean environment).
Attempt to create bibliography with biber on valid LaTeX project.
   `pdflatex foo.tex && biber foo`
Install net/p5-URI and repeat, should now work.
Comment 1 Tobias Brodel 2016-03-25 05:36:42 UTC
Created attachment 168595 [details]
poudriere log for print/latex-biber
Comment 2 commit-hook freebsd_committer 2018-03-14 11:39:26 UTC
A commit references this bug:

Author: tobik
Date: Wed Mar 14 11:38:36 UTC 2018
New revision: 464489
URL: https://svnweb.freebsd.org/changeset/ports/464489

Log:
  print/latex-biber: Add missing net/p5-URI dependency

  PR:		208277
  Submitted by:	Tobias Brodel <brittlehaus@gmail.com>
  Approved by:	hrs (maintainer timeout, 2 years)

Changes:
  head/print/latex-biber/Makefile