Bug 208322 - graphics/blender: Blender 2.76b_1 crashes on startup
Summary: graphics/blender: Blender 2.76b_1 crashes on startup
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-27 10:27 UTC by lumiwa
Modified: 2018-02-25 00:02 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lumiwa 2016-03-27 10:27:31 UTC
Hi!

Mys system is FreeBSD 10.2-RELEASE-p14 #0: Wed Mar 16 20:46:12 UTC 2016     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC  amd64
and I am running GNOME 3.18 and/or Fluxbox.
I did rebuild with Synth all ports related to llvm-3.7.1 included Blender and when I run Blender I got:

Assertion failed: (findOption(Name) == Values.size() && "Option already exists!"), function addLiteralOption, file /construction/xports/devel/llvm37/work/llvm-3.7.1.src/include/llvm/Support/CommandLine.h, line 698.
Abort (core dumped)

Thank you.
Comment 1 Shane 2016-03-29 07:19:17 UTC
Officially blender only supports building with clang/llvm-3.4

https://developer.blender.org/diffusion/B/browse/master/build_files/build_environment/install_deps.sh$312

Personally I built blender from master using clang38 yesterday (outside of ports on 10.3BETA2) and first quick testing appears to run fine. My installed ports are built using poudriere - using systems clang 3.4.1

Are you building all ports with CC=clang38 in make.conf for your synth config? or have you just started using clang38 to rebuild some ports?
Comment 2 lumiwa 2016-04-01 16:36:39 UTC
(In reply to FreeBSD from comment #1)
clang --version
FreeBSD clang version 3.4.1 (tags/RELEASE_34/dot1-final 208032) 20140512
Target: x86_64-unknown-freebsd10.2
Thread model: posix

All ports are rebuild with Synth and pkg upgrade -f
There were no problem. 
Blender works if I build it with Cycles disabled but I like Cycles render.

Thank you.
Comment 3 Rene Ladan freebsd_committer 2017-01-22 22:35:06 UTC
Maintainer reset
Comment 4 lumiwa 2017-02-26 12:51:20 UTC
...and now is the problem if is llvm34 installed than xserver doesn't start and if is not than openshadinglanguage cannot build and again cycles engine are still not usable on FreeBSD.
Comment 5 Shane 2017-02-27 05:32:40 UTC
llvm is only needed to build osl support, using osl scripts hasn't caught on very much, so if you aren't using any osl scripts then you can disable osl and still build cycles without needing llvm installed.

The next release of osl supports using llvm 3.9 and 4.0, and it is currently in RC and was planned to be released by now but got delayed after some fixes were needed. When it is released I can send an update to remove the need for llvm 3.4
Comment 6 Shane 2017-10-21 07:17:38 UTC
The blender port has now been updated to 2.79 - this issue should be resolved.

Can you check if you still have any trouble building and running blender.
Comment 7 Walter Schwarzenfeld freebsd_triage 2018-02-14 18:12:50 UTC
Feedback timeout (Blender starts without problems on 10.4 - 10.2 is EOL)
Comment 8 Walter Schwarzenfeld freebsd_triage 2018-02-25 00:02:05 UTC
Feedba