Bug 208357 - i915kms do not work on mobile IvyBridge after r296719
Summary: i915kms do not work on mobile IvyBridge after r296719
Status: Closed DUPLICATE of bug 221350
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: CURRENT
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-28 10:32 UTC by Vladimir Kondratyev
Modified: 2019-12-03 21:49 UTC (History)
1 user (show)

See Also:


Attachments
verbose boot log (33.95 KB, text/plain)
2016-03-28 10:32 UTC, Vladimir Kondratyev
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Kondratyev freebsd_committer 2016-03-28 10:32:26 UTC
Created attachment 168725 [details]
verbose boot log

On my IvyBridge laptop (Acer Aspire S7-191) vt console cannot output anything to screen before agp(4) is loaded.
r296719 removed SandyBridge support from agp(4) so laptop becomes unusable. It can boot multiuser but screen freezes at one point during a boot.
Reverting r296719 makes things working again.

following is some parts of verbose boot log (full listing is attached) of pre r296719 kernel with agp(4) compiled as module and loaded from command prompt:

random: harvesting attach, 8 bytes (4 bits) from pci_link7
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pcib0: decoding 5 range 0-0xfe
pcib0: decoding 4 range 0-0xcf7
pcib0: decoding 4 range 0xd00-0xffff
pcib0: decoding 3 range 0xa0000-0xbffff
pcib0: decoding 3 range 0x3fa00000-0xfeafffff
pci0: <ACPI PCI bus> on pcib0
pci0: domain=0, physical bus=0
found-> vendor=0x8086, dev=0x0154, revid=0x09
        domain=0, bus=0, slot=0, func=0
        class=06-00-00, hdrtype=0x00, mfdev=0
        cmdreg=0x0006, statreg=0x2090, cachelnsz=0 (dwords)
        lattimer=0x00 (0 ns), mingnt=0x00 (0 ns), maxlat=0x00 (0 ns)
found-> vendor=0x8086, dev=0x0166, revid=0x09
        domain=0, bus=0, slot=2, func=0
        class=03-00-00, hdrtype=0x00, mfdev=0
        cmdreg=0x0007, statreg=0x0090, cachelnsz=0 (dwords)
        lattimer=0x00 (0 ns), mingnt=0x00 (0 ns), maxlat=0x00 (0 ns)
        intpin=a, irq=7
        powerspec 2  supports D0 D3  current D0
        MSI supports 1 message
        map[10]: type Memory, range 64, base rx50000000, size 22, enabled
pcib0: allocated type 3 (0x50000000-0x503fffff) for rid 10 of pci0:0:2:0
        map[18]: type Prefetchable Memory, range 64, base rx40000000, size 28, enabled
>>>>>>>>>>>>>>>>>>>>>>>>>>
Screen updating stops HERE
>>>>>>>>>>>>>>>>>>>>>>>>>>
pci0: pci0:0:2:0 bar 0x18 failed to allocate
        map[20]: type I/O Port, range 32, base rx2000, size  6, enabled
pcib0: allocated type 4 (0x2000-0x203f) for rid 20 of pci0:0:2:0
pcib0: matched entry for 0.2.INTA
pcib0: slot 2 INTA hardwired to IRQ 16
>>>>>>>>>>>>>>>>>>>>>>>>>>
Some output skipped
>>>>>>>>>>>>>>>>>>>>>>>>>>
SMP: passed TSC synchronization test
Timecounter "TSC" frequency 1795968296 Hz quality 1000
Trying to mount root from zfs:zroot/ROOT/default []...
battery0: battery initialization done, tried 1 times
start_init: trying /sbin/init
>>>>>>>>>>>>>>>>>>>>>>>>>>
Now I blindly type "kldload agp" from command prompt
and screen updating starts again
>>>>>>>>>>>>>>>>>>>>>>>>>>
agp0: <IvyBridge mobile GT2 IG> on vgapci0
pcib0: allocated type 3 (0x80000000-0x8fffffff) for rid 18 of vgapci0
vgapci0: Lazy allocation of 0x10000000 bytes rid 0x18 type 3 at 0x80000000
agp0: aperture size is 256M, detected 65532k stolen memory
agp0: AGP_SNB_GFX_MODE: 00000000
agp0: AGP_SNB_GCC1: 0x0211
agp0: Mappable GTT entries: 65536
agp0: Total GTT entries: 524288
random: harvesting attach, 8 bytes (4 bits) from agp0
Comment 1 Vladimir Kondratyev freebsd_committer 2019-12-03 21:49:53 UTC

*** This bug has been marked as a duplicate of bug 221350 ***