Bug 208407 - www/sogo-activesync rename and update to www/sogo2-activesync
Summary: www/sogo-activesync rename and update to www/sogo2-activesync
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on: 208405
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-30 19:04 UTC by Jose Alonso Cardenas Marquez
Modified: 2016-05-02 23:52 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (euan)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jose Alonso Cardenas Marquez freebsd_committer 2016-03-30 19:04:44 UTC
New version of SOGo was released. Version 2 and 3 will be maintained by SOGo project. I have committed devel/sope3, www/sogo3 and www/sogo3-activesync ports recently. 

I think that the best is rename www/sogo, devel/sope and devel/sogo-activesync the same way like other ports are stored on ports tree (mysql55, mysql56, etc). It reflect the current version of these ports.

It needs new entries on ports/MOVED and ports/UPDATING files

www/sogo2-activesync update to 2.3.9 can be obtained from 

https://people.freebsd.org/~acm/ports/sogo2-activesync.diff
Comment 1 Euan Thoms 2016-05-02 06:39:00 UTC
(In reply to Jose Alonso Cardenas Marquez from comment #0)

I agree with your renaming strategy. That was what I intended to do about the two releases.

How do we go about this? Who's job is it to do the renaming?

Also, I have an update for 2.3.10 coming very soon (today probably). How should I proceed with a PR for the upgrade patch?
Comment 2 commit-hook freebsd_committer 2016-05-02 23:07:10 UTC
A commit references this bug:

Author: acm
Date: Mon May  2 23:06:21 UTC 2016
New revision: 414488
URL: https://svnweb.freebsd.org/changeset/ports/414488

Log:
  - Rename www/sogo-activesync to www/sogo2-activesync
  - Update 2.3.10

  PR:		208407
  Submitted by:	me
  Approved by:	Euan Thoms <euan at potensol.com>

Changes:
  head/www/Makefile
  head/www/sogo2-activesync/
  head/www/sogo2-activesync/Makefile