Bug 208450 - net-im/ejabberd: 16.02 broke mod_shared_roster_ldap
Summary: net-im/ejabberd: 16.02 broke mod_shared_roster_ldap
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Ashish SHUKLA
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-01 11:39 UTC by Marko Cupać
Modified: 2016-04-11 02:30 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (ashish)


Attachments
proposed diff (8.37 KB, patch)
2016-04-07 09:06 UTC, Ashish SHUKLA
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Marko Cupać 2016-04-01 11:39:38 UTC
Another problem with ldap in 16.X branch of ejabberd, this time with mod_shared_roster_ldap. It appears the problem is already resolved upstream in 16.03:
https://github.com/processone/ejabberd/issues/986

I'd be grateful if FreeBSD port could be updated to fix the issue.

Regards,
Comment 1 Ashish SHUKLA freebsd_committer 2016-04-01 17:30:18 UTC
Sure, I will work on it this weekend.

Thanks!
Comment 2 Marko Cupać 2016-04-06 09:35:26 UTC
Any news? mod_shared_roster_ldap is still broken in current ejabberd FreeBSD port.

Thank you in advance.
Comment 3 Ashish SHUKLA freebsd_committer 2016-04-07 09:06:42 UTC
Created attachment 169070 [details]
proposed diff

Hi Marko,

I have not finished testing this diff, but will try to get to it around the weekend. In the meantime, could you see if it fixes your issue ?

Thanks!
Ashish
Comment 4 commit-hook freebsd_committer 2016-04-11 02:29:48 UTC
A commit references this bug:

Author: ashish
Date: Mon Apr 11 02:29:34 UTC 2016
New revision: 412993
URL: https://svnweb.freebsd.org/changeset/ports/412993

Log:
  - Update to 16.03
  - Add ZLIB option

  PR:		208450

Changes:
  head/net-im/ejabberd/Makefile
  head/net-im/ejabberd/distinfo
  head/net-im/ejabberd/pkg-plist
Comment 5 Ashish SHUKLA freebsd_committer 2016-04-11 02:30:42 UTC
Committed.

HTH