Bug 208457 - multimedia/ffmpeg: add CHROMAPRINT, GCRYPT, GMP, NETCDF, RUBBERBAND, TESSERACT, ZIMG options
Summary: multimedia/ffmpeg: add CHROMAPRINT, GCRYPT, GMP, NETCDF, RUBBERBAND, TESSERAC...
Status: Closed DUPLICATE of bug 207547
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Thomas Zander
URL:
Keywords: patch, patch-ready
Depends on: 207547 208877 208878
Blocks:
  Show dependency treegraph
 
Reported: 2016-04-01 17:33 UTC by Jan Beich
Modified: 2016-12-14 20:04 UTC (History)
2 users (show)

See Also:
jbeich: maintainer-feedback+


Attachments
v0 (1.41 KB, patch)
2016-04-01 17:33 UTC, Jan Beich
no flags Details | Diff
poudriere bulk -t log (10.1R i386) (130.33 KB, text/plain)
2016-04-01 17:34 UTC, Jan Beich
no flags Details
v1 (5.11 KB, patch)
2016-04-18 00:46 UTC, Jan Beich
jbeich: maintainer-approval? (multimedia)
Details | Diff
poudriere bulk -t log (10.1R i386) (148.70 KB, text/plain)
2016-04-18 00:48 UTC, Jan Beich
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2016-04-01 17:33:03 UTC
Created attachment 168876 [details]
v0

From ffmpeg-filters(1) manpage:

   zscale
       Scale (resize) the input video, using the z.lib library:
       https://github.com/sekrit-twc/zimg.

       The zscale filter forces the output display aspect ratio to be the same
       as the input, by changing the output sample aspect ratio.

       If the input image format is different from the format requested by the
       next filter, the zscale filter will convert the input to the requested
       format.

Basic testing:

  $ ffmpeg -i /path/to/foo.mp4 -vf zscale=w=320:h=-1 bar.mp4
  $ mpv -vf lavfi='"zscale=w=320:h=-1"' /path/to/foo.mp4
Comment 1 Jan Beich freebsd_committer 2016-04-01 17:34:27 UTC
Created attachment 168877 [details]
poudriere bulk -t log (10.1R i386)
Comment 2 Jan Beich freebsd_committer 2016-04-18 00:46:07 UTC
Created attachment 169412 [details]
v1

More options from |configure --help| diff. These should have been part of bug 207547.
Comment 3 Jan Beich freebsd_committer 2016-04-18 00:48:25 UTC
Created attachment 169413 [details]
poudriere bulk -t log (10.1R i386)
Comment 4 Thomas Zander freebsd_committer 2016-05-09 06:12:18 UTC
New OPTIONs have been integrated into updated patch in bug 207547.

Propose to close this pr.
Comment 5 Jan Beich freebsd_committer 2016-05-16 21:49:03 UTC
OK. Nice touch marking CHROMAPRINT as BROKEN but to avoid ambiguity better reference the bug number explicitly.

*** This bug has been marked as a duplicate of bug 207547 ***
Comment 6 commit-hook freebsd_committer 2016-12-14 20:04:06 UTC
A commit references this bug:

Author: jbeich
Date: Wed Dec 14 20:03:17 UTC 2016
New revision: 428588
URL: https://svnweb.freebsd.org/changeset/ports/428588

Log:
  multimedia/ffmpeg: expose GCRYPT, GMP, LIBRTMP options

  GMP is enabled by default as GNUTLS indirectly pulls math/gmp mimicing
  the behavior in ffmpeg-2.8.10.

  PR:		208457 (lost in a mismerge)
  Reported by:	sunpoet

Changes:
  head/multimedia/ffmpeg/Makefile