Bug 208574 - sysutils/webmin: Webmin wrong show local disk space
Summary: sysutils/webmin: Webmin wrong show local disk space
Status: Closed Unable to Reproduce
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Jimmy Olgeni
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-06 11:15 UTC by Vladimir Omelchuk
Modified: 2019-08-05 02:38 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (olgeni)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Omelchuk 2016-04-06 11:15:48 UTC
Hi!
I have 3 hard drive (8 TB) with file system zfs, 
but Webmin wrong show local disk space in the "System Information"!

Webmin show:
Local disk space 3.37 TB used, 5.27 TB total

Real size:
# zpool list
NAME    SIZE  ALLOC   FREE  EXPANDSZ   FRAG    CAP  DEDUP  HEALTH  ALTROOT
dc     3,62T  2,43T  1,19T         -    31%    67%  1.00x  ONLINE  -
dc2    1,81T   964G   892G         -    18%    51%  1.00x  ONLINE  -
zroot  1,80T   198G  1,60T         -     7%    10%  1.00x  ONLINE  -

All disks mounted.

The developers Webmin say, that they have displayed "Local disk space" correctly!
Quote:
"Based on your files and the Webmin code, it should be showing the full 8 TB of disk."

What could be the problem?

Someone else has a similar problem?
Comment 1 Vladimir Omelchuk 2016-05-28 15:19:50 UTC
Updated webmin:

root@vladiom:~ # pkg version -v | grep webmin
webmin-1.800                       =   up-to-date with index

The problem is still present ...

<uname>
FreeBSD 10.3-RELEASE-p3 amd64
Comment 2 Vladimir Omelchuk 2017-02-05 21:32:01 UTC
Updated webmin:

root@vladiom:~ # pkg version -v | grep webmin
webmin-1.831                       =   up-to-date with index

The problem is still present ...

root@vladiom:~ # uname -srm
FreeBSD 10.3-RELEASE-p16 amd64

Webmin show:
Local disk space 3.55 TB used, 5.27 TB total

Real size:
root@vladiom:~ # zpool list
NAME    SIZE  ALLOC   FREE  EXPANDSZ   FRAG    CAP  DEDUP  HEALTH  ALTROOT
dc     3.62T  2.45T  1.17T         -    31%    67%  1.00x  ONLINE  -
dc2    1.81T  1.09T   738G         -    20%    60%  1.00x  ONLINE  -
zroot  1.80T   316G  1.49T         -    17%    17%  1.00x  ONLINE  -
Comment 3 Walter Schwarzenfeld freebsd_triage 2018-02-10 06:01:28 UTC
Feedback please!
Comment 4 Vladimir Omelchuk 2018-02-10 08:18:41 UTC
(In reply to w.schwarzenfeld from comment #3)

The problem is still present ...

root@vladiom:~ # pkg version -v | grep webmin
webmin-1.870                       =   up-to-date with index

root@vladiom:~ # uname -srm
FreeBSD 11.1-RELEASE-p6 amd64

Webmin show:
Local disk space 3.67 TB used, 5.27 TB total

Real size:
root@vladiom:~ # zpool list
NAME    SIZE  ALLOC   FREE  EXPANDSZ   FRAG    CAP  DEDUP  HEALTH  ALTROOT
dc     3.62T  2.56T  1.06T         -    33%    70%  1.00x  ONLINE  -
dc2    1.81T  1.11T   720G         -    20%    61%  1.00x  ONLINE  -
zroot  1.80T   442G  1.37T         -    36%    24%  1.00x  ONLINE  -
Comment 5 Walter Schwarzenfeld freebsd_triage 2018-03-06 15:05:38 UTC
Please, test with recent committed new version 1.880.
Comment 6 Vladimir Omelchuk 2018-03-06 23:24:58 UTC
(In reply to w.schwarzenfeld from comment #5)

No, nothing has changed :(
The problem is still present ...

root@vladiom:~ # pkg version -v | grep webmin
webmin-1.880                       =   up-to-date with index

root@vladiom:~ # uname -srm
FreeBSD 11.1-RELEASE-p6 amd64

Webmin show:
Local disk space 3.67 TB used, 5.27 TB total

Real size:
root@vladiom:~ # zpool list
NAME    SIZE  ALLOC   FREE  EXPANDSZ   FRAG    CAP  DEDUP  HEALTH  ALTROOT
dc     3.62T  2.56T  1.06T         -    33%    70%  1.00x  ONLINE  -
dc2    1.81T  1.11T   715G         -    20%    61%  1.00x  ONLINE  -
zroot  1.80T   459G  1.35T         -    37%    24%  1.00x  ONLINE  -