Bug 208602 - security/openssl: pkg-plist needs a fix
Summary: security/openssl: pkg-plist needs a fix
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Dirk Meyer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-07 12:55 UTC by timp87
Modified: 2016-05-04 05:56 UTC (History)
0 users

See Also:
dinoex: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description timp87 2016-04-07 12:55:27 UTC
Hi!

It's openssl-1.0.2_11, default options.

root@fbsd11:/usr/ports/security/openssl # env DEVELOPER=yes make stage && make check-plist && make package

....
====> Compressing man pages (compress-man)
====> Running Q/A tests (stage-qa)
Warning: 'bin/openssl' is not stripped consider trying INSTALL_TARGET=install-strip or using ${STRIP_CMD}
Warning: 'lib/engines/lib4758cca.so' is not stripped consider trying INSTALL_TARGET=install-strip or using ${STRIP_CMD}
Warning: 'lib/engines/libaep.so' is not stripped consider trying INSTALL_TARGET=install-strip or using ${STRIP_CMD}
Warning: 'lib/engines/libatalla.so' is not stripped consider trying INSTALL_TARGET=install-strip or using ${STRIP_CMD}
Warning: 'lib/engines/libcswift.so' is not stripped consider trying INSTALL_TARGET=install-strip or using ${STRIP_CMD}
Warning: 'lib/engines/libgmp.so' is not stripped consider trying INSTALL_TARGET=install-strip or using ${STRIP_CMD}
Warning: 'lib/engines/libchil.so' is not stripped consider trying INSTALL_TARGET=install-strip or using ${STRIP_CMD}
Warning: 'lib/engines/libnuron.so' is not stripped consider trying INSTALL_TARGET=install-strip or using ${STRIP_CMD}
Warning: 'lib/engines/libsureware.so' is not stripped consider trying INSTALL_TARGET=install-strip or using ${STRIP_CMD}
Warning: 'lib/engines/libubsec.so' is not stripped consider trying INSTALL_TARGET=install-strip or using ${STRIP_CMD}
Warning: 'lib/engines/libpadlock.so' is not stripped consider trying INSTALL_TARGET=install-strip or using ${STRIP_CMD}
Warning: 'lib/engines/libcapi.so' is not stripped consider trying INSTALL_TARGET=install-strip or using ${STRIP_CMD}
Warning: 'lib/engines/libgost.so' is not stripped consider trying INSTALL_TARGET=install-strip or using ${STRIP_CMD}
Warning: 'lib/libcrypto.so.8' is not stripped consider trying INSTALL_TARGET=install-strip or using ${STRIP_CMD}
Warning: 'lib/libssl.so.8' is not stripped consider trying INSTALL_TARGET=install-strip or using ${STRIP_CMD}
====> Checking for pkg-plist issues (check-plist)
===> Parsing plist
===> Checking for items in STAGEDIR missing from pkg-plist
Error: Orphaned: man/man3/DTLS_client_method.3.gz
Error: Orphaned: man/man3/DTLS_method.3.gz
Error: Orphaned: man/man3/DTLS_server_method.3.gz
Error: Orphaned: man/man3/DTLSv1_2_client_method.3.gz
Error: Orphaned: man/man3/DTLSv1_2_method.3.gz
Error: Orphaned: man/man3/DTLSv1_2_server_method.3.gz
Error: Orphaned: man/man3/DTLSv1_client_method.3.gz
Error: Orphaned: man/man3/DTLSv1_method.3.gz
Error: Orphaned: man/man3/DTLSv1_server_method.3.gz
Error: Orphaned: man/man3/SSLv23_client_method.3.gz
Error: Orphaned: man/man3/SSLv23_method.3.gz
Error: Orphaned: man/man3/SSLv23_server_method.3.gz
Error: Orphaned: man/man3/SSLv2_client_method.3.gz
Error: Orphaned: man/man3/SSLv2_method.3.gz
Error: Orphaned: man/man3/SSLv2_server_method.3.gz
Error: Orphaned: man/man3/SSLv3_client_method.3.gz
Error: Orphaned: man/man3/SSLv3_method.3.gz
Error: Orphaned: man/man3/SSLv3_server_method.3.gz
Error: Orphaned: man/man3/TLSv1_1_client_method.3.gz
Error: Orphaned: man/man3/TLSv1_1_method.3.gz
Error: Orphaned: man/man3/TLSv1_1_server_method.3.gz
Error: Orphaned: man/man3/TLSv1_2_client_method.3.gz
Error: Orphaned: man/man3/TLSv1_2_method.3.gz
Error: Orphaned: man/man3/TLSv1_2_server_method.3.gz
Error: Orphaned: man/man3/TLSv1_client_method.3.gz
Error: Orphaned: man/man3/TLSv1_method.3.gz
Error: Orphaned: man/man3/TLSv1_server_method.3.gz
===> Checking for items in pkg-plist which are not in STAGEDIR
===> Error: Plist issues found.
*** Error code 1

Stop.
make: stopped in /usr/ports/security/openssl
Comment 1 commit-hook freebsd_committer 2016-04-07 14:39:34 UTC
A commit references this bug:

Author: dinoex
Date: Thu Apr  7 14:39:14 UTC 2016
New revision: 412667
URL: https://svnweb.freebsd.org/changeset/ports/412667

Log:
  - add some more manpages
  PR:		208602
  Submitted by:	timp87@gmail.com

Changes:
  head/security/openssl/pkg-plist
Comment 2 commit-hook freebsd_committer 2016-05-04 05:56:45 UTC
A commit references this bug:

Author: dinoex
Date: Wed May  4 05:56:29 UTC 2016
New revision: 414584
URL: https://svnweb.freebsd.org/changeset/ports/414584

Log:
  MFH: r412526 r412667 r414534

  - remove NOPRECIOUS*
  - make portlint happier

  - add some more manpages
  PR:		208602
  Submitted by:	timp87@gmail.com

  - Security update to 1.0.2h
  Security: https://www.openssl.org/news/secadv/20160503.txt
  Security: CVE-2016-2105
  Security: CVE-2016-2106
  Security: CVE-2016-2107
  Security: CVE-2016-2108
  Security: CVE-2016-2109
  Security: CVE-2016-2176

  Approved by:	portmgr (Jason Unovitch)

Changes:
_U  branches/2016Q2/
  branches/2016Q2/security/openssl/Makefile
  branches/2016Q2/security/openssl/distinfo
  branches/2016Q2/security/openssl/pkg-plist