Bug 208658 - mail/mutt: get rid of USE_AUTOTOOLS
Summary: mail/mutt: get rid of USE_AUTOTOOLS
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kurt Jaeger
URL:
Keywords:
: 208690 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-04-09 19:16 UTC by Kurt Jaeger
Modified: 2016-04-11 07:05 UTC (History)
3 users (show)

See Also:
pi: maintainer-feedback+


Attachments
patch (1001 bytes, patch)
2016-04-09 19:16 UTC, Kurt Jaeger
no flags Details | Diff
patch for 1.6.0 fixing idea when no iconv is installed (7.02 KB, patch)
2016-04-10 12:29 UTC, Udo.Schweigert
Udo.Schweigert: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kurt Jaeger freebsd_committer 2016-04-09 19:16:10 UTC
Created attachment 169129 [details]
patch

The port makefile still causes this warning:

USE_AUTOTOOLS is deprecated, please use USES=autoreconf and GNU_CONFIGURE=yes

Attached is a patch that tries to implement a fix for this (and one small other fix).

Testbuilds are fine.
Comment 1 Udo.Schweigert 2016-04-09 20:50:08 UTC
Looks good, I will test soon. The GNU_CONFIGURE option should read "yes" I think.
Comment 2 Udo.Schweigert 2016-04-10 12:29:32 UTC
Created attachment 169143 [details]
patch for 1.6.0 fixing idea when no iconv is installed

Attached patch additionally adds code which keeps mutt running even when no libiconv is installed, cf. https://dev.mutt.org/trac/wiki/UpgradingTips. This will be fixed with mutt 1.6.1 - until then we use the upstream patch included. Therefore PORTREVISION is bumped.
Comment 3 Udo.Schweigert 2016-04-10 12:38:47 UTC
Forgot to mention: this especially fixes the mutt-lite slave port.
Comment 4 Kurt Jaeger freebsd_committer 2016-04-10 12:41:11 UTC
testbuilds@work
Comment 5 commit-hook freebsd_committer 2016-04-10 12:53:36 UTC
A commit references this bug:

Author: pi
Date: Sun Apr 10 12:53:27 UTC 2016
New revision: 412928
URL: https://svnweb.freebsd.org/changeset/ports/412928

Log:
  mail/mutt: some fixes

  - changed from USE_AUTOTOOLS (deprecated) to USES=autoreconf
  - mutt-lite slave port fix for no-libiconv-case

  PR:		208658
  Submitted by:	Udo Schweigert <Udo.Schweigert@siemens.com> (maintainer)

Changes:
  head/mail/mutt/Makefile
  head/mail/mutt/files/extra-patch-idna_no_iconv
Comment 6 Kurt Jaeger freebsd_committer 2016-04-10 12:54:07 UTC
Committed, thanks!
Comment 7 Jeremy Chadwick 2016-04-11 07:05:27 UTC
*** Bug 208690 has been marked as a duplicate of this bug. ***