Bug 208690 - mail/mutt-lite: r412853: lack of IDN + iconv breaks aliases
Summary: mail/mutt-lite: r412853: lack of IDN + iconv breaks aliases
Status: Closed DUPLICATE of bug 208658
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Many People
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-11 06:14 UTC by Jeremy Chadwick
Modified: 2016-04-11 10:05 UTC (History)
1 user (show)

See Also:
Udo.Schweigert: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Chadwick 2016-04-11 06:14:11 UTC
Issue: mutt-lite excludes IDN and iconv support (which is totally OK! There's nothing wrong there!), however broken/bad code within mutt 1.6.0 causes this to break aliases unconditionally.  Example:

Error in /home/jdc/.muttrc, line 235: Warning: Bad IDN 'some.email@gmail.com' in alias 'steven'.

Confirmation of the bug is here:

http://marc.info/?t=145986541700003&r=1&w=2

Fix: author of mutt has released a patch, which users confirm fix the problem:

http://marc.info/?t=145989282100002&r=1&w=2

Please incorporate this patch into files/ but BE SURE to read Kevin's notes about the patch before doing so!
Comment 1 Udo.Schweigert 2016-04-11 06:37:55 UTC
Has been solved already with mutt-lite-1.6.0_1: 

bug #208658
ports r412928
Comment 2 Jeremy Chadwick 2016-04-11 07:05:27 UTC
Perfect.  Thank you!

*** This bug has been marked as a duplicate of bug 208658 ***
Comment 3 Udo.Schweigert 2016-04-11 10:05:50 UTC
Sorry, there was still an issue, the correct solution has been submitted in bug #208694