Bug 208759 - security/libressl: relocation R_X86_64_32 against `a local symbol' ...
Summary: security/libressl: relocation R_X86_64_32 against `a local symbol' ...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Many People
Assignee: Bernard Spil
URL: reviews.freebsd.org/D5902
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-12 22:39 UTC by Markus Kohlmeyer
Modified: 2016-10-08 15:54 UTC (History)
2 users (show)

See Also:


Attachments
portupgrade build log with error (38.71 KB, text/plain)
2016-04-12 22:39 UTC, Markus Kohlmeyer
no flags Details
portupgrade build log with error and -fPIC for MySQL (38.72 KB, text/plain)
2016-04-12 23:02 UTC, Markus Kohlmeyer
no flags Details
used portfiles to reproduce error (105.00 KB, application/octet-stream)
2016-04-12 23:08 UTC, Markus Kohlmeyer
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Kohlmeyer 2016-04-12 22:39:14 UTC
Created attachment 169267 [details]
portupgrade build log with error

While working on https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=206998 i got this error while linking MySQL 5.7.12 against security/libressl-devel-2.3.3
Linking against security/openssl-1.0.2_11 works without any error.
Attached build log produced by portupgrade.
Comment 1 Markus Kohlmeyer 2016-04-12 23:02:05 UTC
Created attachment 169268 [details]
portupgrade build log with error and -fPIC for MySQL

This is the build log with enabled -fPIC for MySQL, which results in the same error.
Comment 2 Markus Kohlmeyer 2016-04-12 23:08:34 UTC
Created attachment 169269 [details]
used portfiles to reproduce error

These are the portfiles i used to trigger the bug
Comment 3 Bernard Spil freebsd_committer 2016-04-13 14:12:51 UTC
Hi Markus,

Can you please try this a LibreSSL version that adds a 

> CFLAGS+= -fPIC

to the Makefile and then recompile MySQL 5.7

This has been tested for D5902 and works. You can download a diff there but beware that this also updates LibreSSL to the now released 2.3 branch.
Comment 4 Markus Kohlmeyer 2016-04-13 14:41:43 UTC
Hi Bernard,

that solved the problem, thanks.
Will this go in for libressl-devel too?
Comment 5 Bernard Spil freebsd_committer 2016-04-13 15:02:14 UTC
Thanks for the confirmation!

Once the update for security/libressl is finished, this will also be committed to libressl-devel.
Comment 6 Markus Kohlmeyer 2016-04-13 15:05:12 UTC
Thanks for your fast responds and the fix.
Comment 7 Mahdi Mokhtari freebsd_committer freebsd_triage 2016-04-13 15:08:06 UTC
(In reply to Bernard Spil from comment #3)
Worked for me too ;)
poudirere QA confirmed 10.X 11.X :D

So we can continue on rest of MySQL stuffs (cause it fixed :D)
Thanks all guys.
Comment 8 commit-hook freebsd_committer 2016-05-03 21:16:08 UTC
A commit references this bug:

Author: brnrd
Date: Tue May  3 21:15:44 UTC 2016
New revision: 414560
URL: https://svnweb.freebsd.org/changeset/ports/414560

Log:
  security/libressl: Update to 2.3.4

    - Upstream marked the 2.3 branch as stable
    - Bump SHLIB_VERSION in bsd.openssl.mk
    - Note SHLIB_VERSION bump and SSLv3 removal in UPDATING
    - Add TLS-enabled netcat binary
    - Fix linking issues with MySQL 5.7 [1]
    - Includes vulnerability fixes [2]

  PR:		208759 [1]
  Security:	01d729ca-1143-11e6-b55e-b499baebfeaf [2]
  Reviewed_by:	feld (mentor), koobs (mentor)
  Approved by:	feld (mentor, ports-secteam)
  Differential Revision:	D5902

Changes:
  head/security/libressl/Makefile
  head/security/libressl/distinfo
  head/security/libressl/pkg-plist