Bug 208783 - lang/polyml: update from 5.5.2 to 5.6
Summary: lang/polyml: update from 5.5.2 to 5.6
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Kurt Jaeger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-13 16:57 UTC by Phil Eaton
Modified: 2016-04-15 19:59 UTC (History)
3 users (show)

See Also:
beyert: maintainer-feedback+


Attachments
the patch file (2.12 KB, text/plain)
2016-04-13 16:57 UTC, Phil Eaton
no flags Details
Corrected attachment with shared libraries and fixes -lstdc++ error (1.62 KB, patch)
2016-04-15 02:29 UTC, Timothy Beyer
no flags Details | Diff
Yet another revised diff (use this one) (1.64 KB, patch)
2016-04-15 03:56 UTC, Timothy Beyer
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Phil Eaton 2016-04-13 16:57:24 UTC
Created attachment 169293 [details]
the patch file

This patch updates the Poly/ML port from 5.5.2 to 5.6, the next and most recent release.
Comment 1 Torsten Zühlsdorff 2016-04-14 12:26:18 UTC
Hello Phil,

just read your email. First: thank you very much for your work! :)

Some advises:

It helps very much if you add the category in the headline. Like this:
lang/polyml: update from 5.5.2 to 5.6.

If the port already exists create a diff. You added a shar which contains everything, while a diff just include the changes.

Please add if you did tests like compiling or runtime tests and if yes, for which plattforms.

Also there is a handbook available to help with working on ports. I don't know if you already knew it, so here a link:
https://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/

Thanks again,
Torsten
Comment 2 Mathieu Arnold freebsd_committer 2016-04-14 12:58:45 UTC
Pitching in, add if you tested it, but please, do not attach successful build logs, they will never, ever, be read.

You can add URLs to those build logs if you like, but you don't have to.
Comment 3 Timothy Beyer 2016-04-15 01:35:58 UTC
Hi, I'm the maintainer.

Thanks for the update, I haven't had a chance to put as much time into this port as I would like, especially compared to mlton, so it's been somewhat neglected.

A shar is OK with me, although a unified diff is the standard.  I need to test it to make sure that there aren't any regressions.

Thanks, and I'll try compiling it in the next few days.

I only found out about this PR because Phil contacted me directly, I'm not sure why a notification was not sent to me, so I activated maintainer-feedback.
Comment 4 Timothy Beyer 2016-04-15 02:29:13 UTC
Created attachment 169327 [details]
Corrected attachment with shared libraries and fixes -lstdc++ error

I just tested the patch.  It was missing the post-patch steps which prevented it from compiling on my machine, and it didn't install the generated .so files, which were missing in the pkg-plist (to be fair, the NetBSD pkgsrc version lacked the .so files).

I have attached a diff that corrects both of these issues, and additionally remedies #199566.  Thanks!

Regards,
Tim
Comment 5 Timothy Beyer 2016-04-15 02:31:15 UTC
Modified version of the submission is approved, I set maintainer-feedback to +.

Thanks.
Comment 6 Timothy Beyer 2016-04-15 03:56:25 UTC
Created attachment 169328 [details]
Yet another revised diff (use this one)

I made a small correction to ensure that the diff is relative to the ports verison.  Use this patch instead of my prior submission.
Comment 7 Kurt Jaeger freebsd_committer 2016-04-15 19:47:26 UTC
testbuilds@work
Comment 8 commit-hook freebsd_committer 2016-04-15 19:58:11 UTC
A commit references this bug:

Author: pi
Date: Fri Apr 15 19:58:04 UTC 2016
New revision: 413374
URL: https://svnweb.freebsd.org/changeset/ports/413374

Log:
  lang/polyml: 5.5.2 -> 5.6

  Changes:
  - New foreign-function interface (Foreign structure).
  - Reimplemented debugger so that code with debugging enabled is much faster.
  - Improved support for Poly/ML on native Windows.
  - Support for MIPS and 64-bit ARM processors through the byte-code interpreter.
  - Various bug fixes.

  PR:		208783, 199566
  Submitted by:	Phil Eaton <philneaton95@gmail.com>, brooks
  Approved by:	Timothy Beyer <beyert@cs.ucr.edu> (maintainer)

Changes:
  head/lang/polyml/Makefile
  head/lang/polyml/distinfo
  head/lang/polyml/pkg-plist
Comment 9 Kurt Jaeger freebsd_committer 2016-04-15 19:59:31 UTC
Committed, thanks!