Bug 208911 - devel/libedit: removes escape characters from prompt
Summary: devel/libedit: removes escape characters from prompt
Status: Closed Feedback Timeout
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Walter Schwarzenfeld
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-19 07:01 UTC by Thomas Quinot
Modified: 2019-08-08 09:50 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (bapt)


Attachments
test case (160 bytes, text/plain)
2016-04-19 07:01 UTC, Thomas Quinot
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Quinot freebsd_committer 2016-04-19 07:01:06 UTC
Created attachment 169460 [details]
test case

The ports libedit incorrectly removes ESC characters from the prompt, thus corrupting output when using a colored prompt. Both libreadline and the base libedit pass ESC unaltered.
Comment 1 John Hein 2016-08-22 14:05:07 UTC
Can you test against the recently released 20160618 version of libedit?  It was briefly in the ports tree but had some (unknown to me) trouble with mysql, so you'll have to manually update your libedit port to test it (see libedit commits on June 18 & 19).
Comment 2 Walter Schwarzenfeld freebsd_triage 2018-01-10 13:48:27 UTC
Is this still a problem, I could not reproduce it.
Comment 3 Walter Schwarzenfeld freebsd_triage 2019-08-08 09:50:16 UTC
Feedback timeout! If there still problems, please, reopen.