Bug 208923 - devel/llvm38: libclang_rt.profile-x86_64.a: No such file: No such file or directory
Summary: devel/llvm38: libclang_rt.profile-x86_64.a: No such file: No such file or dir...
Status: Closed DUPLICATE of bug 208900
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Brooks Davis
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-19 18:29 UTC by Aleksander Alekseev
Modified: 2016-04-24 17:45 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (brooks)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aleksander Alekseev 2016-04-19 18:29:43 UTC
# Steps to reproduce

Build any C or C++ project (e.g. PostgreSQL) using:

```
CFLAGS="-O0 -g -fprofile-arcs -ftest-coverage" LDFLAGS="-lgcov"
```

# Expected result

Code compiles and generates coverage information (*.gcda files) during `make check`

# Actual result

./configure fails with following error --- /usr/bin/ld: /usr/local/llvm38/bin/../lib/clang/3.8.0/lib/freebsd/libclang_rt.profile-x86_64.a: No such file: No such file or directory
Comment 1 Brooks Davis freebsd_committer 2016-04-20 17:06:44 UTC
compiler-rt doesn't build in tree any more, but also doesn't build property out of tree.  It should be entirely possible to fix, but I have not had time to do so.

*** This bug has been marked as a duplicate of bug 208900 ***
Comment 2 commit-hook freebsd_committer 2016-04-24 16:14:33 UTC
A commit references this bug:

Author: brooks
Date: Sun Apr 24 16:14:09 UTC 2016
New revision: 413948
URL: https://svnweb.freebsd.org/changeset/ports/413948

Log:
  Upgrade to a new snapshot.

  Build compiler-rt alongside LLVM.  It requires clang headers that we don't
  install because they are incompatible with FreeBSD headers.  To make this
  work, configure and build compiler-rt in the post-build phase against the
  built, but not yet installed llvm tree.

  PR:		208900, 208923

Changes:
  head/MOVED
  head/devel/Makefile
  head/devel/compiler-rt-devel/
  head/devel/llvm-devel/Makefile
  head/devel/llvm-devel/Makefile.snapshot
  head/devel/llvm-devel/distinfo
  head/devel/llvm-devel/pkg-plist
Comment 3 commit-hook freebsd_committer 2016-04-24 17:45:45 UTC
A commit references this bug:

Author: brooks
Date: Sun Apr 24 17:44:55 UTC 2016
New revision: 413953
URL: https://svnweb.freebsd.org/changeset/ports/413953

Log:
  Build compiler-rt on i386 and amd64.

  It should be possible to enable on other other architectures, but I have no
  way to build the PLIST_FILES variables.

  PR:		208900, 208923

Changes:
  head/devel/llvm38/Makefile
  head/devel/llvm38/distinfo
  head/devel/llvm38/files/compiler-rt-patch-svn-261229
  head/devel/llvm38/pkg-plist