Bug 209184 - mail/dspam: Fails to build due to typo in patch files
Summary: mail/dspam: Fails to build due to typo in patch files
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Jason Unovitch
URL:
Keywords: easy, patch, patch-ready, regression
Depends on:
Blocks:
 
Reported: 2016-05-01 19:53 UTC by danny
Modified: 2016-05-01 21:37 UTC (History)
2 users (show)

See Also:


Attachments
mail-dspam-2016050100.patch (1.25 KB, patch)
2016-05-01 19:53 UTC, danny
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description danny 2016-05-01 19:53:12 UTC
Created attachment 169856 [details]
mail-dspam-2016050100.patch

mail/dspam is failing to build after commit r414374 (PR #115957):

  ===>  Patching for dspam-3.10.2_2
  ===>  Applying FreeBSD patches for dspam-3.10.2_2
  Ignoring previously applied (or reversed) patch.
  1 out of 1 hunks ignored--saving rejects to src/client.c.rej
  => Patch patch-src__client.c failed to apply cleanly.
  => Patch(es) patch-src__Makefile.in applied cleanly.
  *** Error code 1

  Stop.
  make[1]: stopped in /usr/ports/mail/dspam
  *** Error code 1

  Stop.
  make: stopped in /usr/ports/mail/dspam

It looks like the contents of patch-src__client.c and patch-src__daemon.c were applied twice, which you can see here:

  https://svnweb.freebsd.org/ports/head/mail/dspam/files/patch-src__client.c?view=markup&pathrev=414374
  https://svnweb.freebsd.org/ports/head/mail/dspam/files/patch-src__daemon.c?view=markup&pathrev=414374

Attached is a quick patch for the fix.
Comment 1 commit-hook freebsd_committer 2016-05-01 21:08:02 UTC
A commit references this bug:

Author: junovitch
Date: Sun May  1 21:07:06 UTC 2016
New revision: 414426
URL: https://svnweb.freebsd.org/changeset/ports/414426

Log:
  mail/dspam: fix build; remove duplicate patch hunks in to files

  PR:		209184
  Submitted by:	Danny Warren <danny@dannywarren.com> (maintainer)
  Pointy hat to:	junovitch

Changes:
  head/mail/dspam/files/patch-src__client.c
  head/mail/dspam/files/patch-src__daemon.c
Comment 2 Jason Unovitch freebsd_committer 2016-05-01 21:11:29 UTC
Ooops, sorry!  Since these two files were additions they didn't get removed completely when I did a 'svn revert -R .' under mail/dspam and the patch hunks got duplicated when I applied your final patch.  I had already QA'd everything earlier so didn't recheck right before committing.

Thanks!
Comment 3 danny 2016-05-01 21:33:44 UTC
Thanks for the fast fix Jason!  Looks good in svn, waiting for it to hit portsnap so I can test it on one of my wild boxes.

I was having similar problems when working on the patches with svn not removing src__dspam.c all the way, annoying.

Anyhow, appreciate it!
Comment 4 danny 2016-05-01 21:37:31 UTC
Change just hit portsnap, can confirm everything works great on a wild mail server.  Thanks!