Bug 209288 - devel/libinotify: Update port
Summary: devel/libinotify: Update port
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Xin LI
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2016-05-05 15:48 UTC by Tobias Kortkamp
Modified: 2016-05-07 07:33 UTC (History)
3 users (show)

See Also:
delphij: maintainer-feedback+


Attachments
libinotify.diff (2.03 KB, patch)
2016-05-05 15:48 UTC, Tobias Kortkamp
tobik: maintainer-approval? (delphij)
Details | Diff
Poudriere testport log FreeBSD 10.2/amd64 (34.48 KB, text/x-log)
2016-05-05 15:49 UTC, Tobias Kortkamp
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Kortkamp freebsd_committer 2016-05-05 15:48:20 UTC
Created attachment 169996 [details]
libinotify.diff

See https://github.com/dmatveev/libinotify-kqueue/pull/35 for changes.

Upstream moved to a new repository too at: https://github.com/libinotify-kqueue/libinotify-kqueue
Comment 1 Tobias Kortkamp freebsd_committer 2016-05-05 15:49:00 UTC
Created attachment 169997 [details]
Poudriere testport log FreeBSD 10.2/amd64
Comment 2 Vladimir Kondratyev freebsd_committer 2016-05-05 20:40:13 UTC
That should be noted that recent changes in CURRENT, namely r298922 and r298982 should allow kernel to pass all regression tests except symlinks-related

Also one of the reasons of https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=204366 is fixed so patch patch-src_inotifywatch.c can be removed from sysutils/inotify-tools
Comment 3 Vladimir Kondratyev freebsd_committer 2016-05-05 22:18:25 UTC
I'm added maintainer of sysutils/inotify-tools to CC list
Comment 4 Yuri Victorovich freebsd_committer 2016-05-06 05:31:46 UTC
Thanks. It looks like sysutils/inotify-tools is probably unaffected.
Comment 5 commit-hook freebsd_committer 2016-05-07 07:32:25 UTC
A commit references this bug:

Author: delphij
Date: Sat May  7 07:31:58 UTC 2016
New revision: 414761
URL: https://svnweb.freebsd.org/changeset/ports/414761

Log:
  Update to 20160505 snapshot with new upstream location.

  PR:		ports/209288
  Submitted by:	Tobias Kortkamp <t tobik me>

Changes:
  head/devel/libinotify/Makefile
  head/devel/libinotify/distinfo
  head/devel/libinotify/pkg-descr
  head/devel/libinotify/pkg-message
Comment 6 Xin LI freebsd_committer 2016-05-07 07:33:12 UTC
Committed, thanks!